Hello Everyone !

I've posted this question before, but haven't been able to resolve the problem nor had any suggestions dropped lately.

I just need a little help to get started on this application that I am tryin to package, Adobe Postscript Printer Driver 1.0. When I run the set up manually, I have to specify if its a local printer or network printer and all that. After googlin out for other options I tried to do a silent install by running setup.exe /s from command line but that doesnt do anything for me.

Then someone suggested me to create a response file using setup.exe /r, which I did and placed the response file in the same directory as the setup.exe file, copied the files on other workstations and used setup.exe /s, but a dialog box opens up to specify if its a Local Printer or Network Shared. How do I get this thing installed silently and uninstall it with no UI.

Appreciate your help !
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
The reason it is failing on the answer file is because setup.exe is spawning a second process that does not get handled by the answer file. I don't know how that would be handled but if it was my app to manage I would repackage it. That way I would have an MSI instead of a legacy setup to deploy.
Answered 07/08/2009 by: joedown
Second Degree Brown Belt

Please log in to comment
0
Ok ! I tried that too ! Did a set up capture, created a msi. But when I install the msi, i don't get the "Generic PostScript Printer" in ControPanel \Printers and Faxes, which is present when a hand install is done.
Answered 07/08/2009 by: shiva2golu
Senior Yellow Belt

Please log in to comment
0
After you run your captured msi install and do a reboot does the Generic PostScript Printer appear in the Printers and Faxes list? Either way most likely this is probably an issue with starting and stopping the spooler service. ProcMon is your friend in these situations

ORIGINAL: shiva2golu

Ok ! I tried that too ! Did a set up capture, created a msi. But when I install the msi, i don't get the "Generic PostScript Printer" in ControPanel \Printers and Faxes, which is present when a hand install is done. 
Answered 07/08/2009 by: joedown
Second Degree Brown Belt

Please log in to comment
0
http://itninja.com/question/gnu,-freeware-and-shareware-programs-to-cloning9673

you are not seeing the printer because you have not captured the hardware registry settings and you will need to stop and start the spooler service during installation and uinstallation if you want
Answered 07/09/2009 by: cygan
Fifth Degree Brown Belt

Please log in to comment
0
Thanks so much for you suggestion guys ! Doing a set up capture and creating a msi did the trick, probably i missed some registry entries while trying the same thing earlier. The machine needs to be rebooted though after installing the msi, which shouldn't be a problem. Thanks again !
Answered 07/09/2009 by: shiva2golu
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity