Hi all,

my msi is having a Prereq like .net 2.0 sp1 after build my msi i install in xpsp3 that os already having .net 2.0

here my question is that i need to uninstall that existing .net2.0 in xpxp3 and install the .net2.0 sp1

kindly tell me the process of prereq upgrading
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
wo hoooo why do you need to uninstall .net [8|] .....it is a framework on which various applications work...what would happen to the other applications which are depending on this version of .net....are you [:-]
Answered 06/20/2011 by: rajdera1
Orange Belt

Please log in to comment
-2
Hi raj,

Tell me how to upgrade the existing .net 2.0 with the .net2.0sp1

with the msi...
Answered 06/20/2011 by: hari4243
Purple Belt

Please log in to comment
0
read this blog http://blogs.msdn.com/b/heaths/archive/2008/04/18/microsoft-net-framework-2-0-service-pack-1-fails-to-install.aspx
Answered 06/20/2011 by: rajdera1
Orange Belt

Please log in to comment
0
hi Hari,

For most of the organisations .net will be handled and deployed globally with the latest versions(3.5 or 4.0)....
in this case you need to check if .net is handled globally if not check this site "http://support.microsoft.com/kb/951950" for 2.0sp1 upgrade
or go with latest version package.
Answered 06/20/2011 by: sunny07
Senior Yellow Belt

Please log in to comment
-2
Hi Sunny,

My question is that in my pc already .net 2.0 is installed and my msi is having an prereq .net2.0sp1 for that write a CA using

the batch script but the thing is it is uninstalling the existing .net2.0 and installing the ,net2.0sp1 on the pc.

but i don't want like that i want like it is not uninstall the existing .net2.0 on that i need to upgrade the .nt2.0sp1 for that how

can i proceed...
Answered 06/20/2011 by: hari4243
Purple Belt

Please log in to comment
0
I just wanted to open new topic about almost same issue. Thing is, that some common applications, which has installshield setup, requires Direct X cabs and redistributable 2005 / 2008 packages. First I invented to install latest versions of those, and then to start repackage software installations to .msi. But the problem is, that when I start to record the installation on virtual machine with lates redistributables and Direct X installed, setup program still requires older versions of those to be installed.

Could someone explain to me, how this issue should be solved?
Answered 06/20/2011 by: yannara
Blue Belt

Please log in to comment
0
hi Hari...

If you see the above link it says that .net2.0sp1 is a major upgrade of .net2.0 and so it will uninstall whenever 2.0sp1 is installed on 2.0

so only either of the one will be existing.

My suggestion will be to repackage .net2.0sp1 as seperate pacakge and mark it as a pre-requisite.
Answered 06/22/2011 by: sunny07
Senior Yellow Belt

Please log in to comment
-2
hi sunny,

In my msi i have .net2.0sp1 if i install in an Os that already having .net2.0sp2 means generally error will occur but my msi simply uninstall that .net2.0sp2 and installin gmy .net2.0sp1 that is the problem i'm facing with my prrerequisities

tell me pls where i need to oimprove..my Knowledge..
Answered 06/23/2011 by: hari4243
Purple Belt

Please log in to comment
0
Take the log file and check what exactly is happening.

Couple of questions..

Have you captured the exe to an msi or you are creating an msi for new application?
Answered 06/23/2011 by: naveen.packager
Green Belt

Please log in to comment
0
my msi simply uninstall that .net2.0sp2 and installin gmy .net2.0sp1Clearly, then, the test in your MSI for .Net 2.0 SPx isn't working.

You should also decide what the actual problem is. First you told us that it was uninstalling v2.0 and installing v2.0 SP1. Now you're saying that it's uninstalling SP2 and installing SP1.
Answered 06/24/2011 by: VBScab
Red Belt

Please log in to comment
-4
sorry for that VBs...

i'm try that using the log file....

Thanks for that reply....
Answered 06/24/2011 by: hari4243
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity