I am packaging Lous Notes 8 and having a problem which I was wondering you might be able to help with?

The data files containing the notes.ini are kept on the network but I cant put in the networked path as the installation will fail when being rolled out via group policy as the network path has not been mapped at installation time.

I therefore wanted to add the arguement in the shortcut to look like this:
"C:\Program Files\lotus\Notes\notes.exe" =u:\notes45\data\notes.ini

But when i modify the properties during the installtion they are overwritten at the end of the install by the default location: "C:\Program Files\lotus\Notes\notes.exe"

I have tried to create a custom action in a vbs file to delete the installed shortcut and copy my version, although this works when the shortcut is used by the user it is overwritten by the one with the default location...

Any ideas??

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Dont use drive letters use the UNC path, problem solved.

P
Answered 07/23/2008 by: Inabus
Second Degree Green Belt

Please log in to comment
0
In our existing version of notes 7.0.2 I used the mapped drive name and it worked so cant understand where/how v8 is overwriting it..
Also to note the drive mappings are on a DFS share and the folder structure is different across each department so this wouldnt work.
IE: \\Domain\shares\Share93\HOME\folder
Answered 07/23/2008 by: MightyMin
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: MightyMin
Also to note the drive mappings are on a DFS share and the folder structure is different across each department so this wouldnt work.
IE: \\Domain\shares\Share93\HOME\folder
You could build a set of conditioned Custom Actions to set a [DEPARTMENT_SHARE] property and then have '\\Domain\shares\[DEPARTMENT_SHARE]\HOME\folder', though, couldn't you? Or do that in script (which is probably more manageable and flexible)?
Answered 07/23/2008 by: VBScab
Red Belt

Please log in to comment
0
I have just done a quick testby setting the DFS share in the data path in the properties - again this fails as during the installation.
I have set the property to the correct path via script, but after installation when the application is launched the shortcut is over-written...

Thanks for your help - hope I can get this sorted soon...
Answered 07/23/2008 by: MightyMin
Senior Yellow Belt

Please log in to comment
0
It sounds to me like the package is self-healing the shortcut. You need to stop the CreateShortcuts action from running. Normally, rather than deleting it, I add an impossible-to-meet condition to it, e.g. '0=1'. You could also simply remove the shortcut(s) from the 'Shortcut' table. Remember to make these changes via a transform file rather than editing the MSI directly.
Answered 07/23/2008 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity