Hi Guys
 
I have been working on this application for 2 days now with no success. 
 
At my work, if we can't package it in AppV, we try to run the vendor media silently and if that fails too then we capture it. 
 
I was able to sequence it in AppV but could not control the licensing. The user can launch the sequenced app but it asks for the license key on the first launch.
 
I have tried but couldn't control it so the next step was to silently install the vendor exe:
 
Create the unattended answer file using Setup.exe -r -f1"c:\setup.iss"
 
Silent installation using Setup.exe -s -f1"c:\setup.iss"
 
Uninstall using "C:\Program Files\InstallShield Installation Information\{AD88355B-A4E0-4DA1-BAC3-EA4FEA930691}\setup.exe" silent
 
The above method works flawlessly locally but when deployed through SCCM 2012 it gives Access Denied error on "C:\Program Files\InstallShield Installation Information" and the installation fails.
 
I captured the installation to an msi and deployed it through SCCM and it failed with error code 1603.
 
 
If anyone has successfully deployed IPSwitch WS_Ftp 12.4 successfully in ANY way please show me the way to do it.
 
Any help is highly appreciated.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2

Well, you can make it work in all the 3 ways if you dig a little deep.

1) App-V : Did you launch the shortcut at sequencing time. Try the opposite.

2) For ISS: It seems that it is trying to copy some file in there and the .iss should have information for it. Open it in notepad and have a look. Delete the entry and try again.

3) For MSI: Remove all the captured information regarding Installshield in the MSI and re compile.

Answered 04/18/2013 by: piyushnasa
Red Belt

Please log in to comment

Answers

1

Hi, Not sure if this will be of much help in your version of application. I have worked on an older version of this application 5.08. It extracts a vendor msi in %temp% folder. I placed my License key to the MSI using a transform with PIDKEY parameter in property it works as expected.

Hope this helps

Answered 04/19/2013 by: gummalla
Senior White Belt

Please log in to comment
1

There was no hidden msi but the following command worked.

wsftp12.4.exe /SILENT /NOREBOOT
"C:\Program Files\Ipswitch\WS_FTP Pro\ipsactive.exe" /a

ipsactive.exe /a - forces the application to activate even if it's already activated and my issue was activation and it worked like a charm.

 

Answered 04/19/2013 by: tellmehow
Senior Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity