Netboot and imaging OSX from same subnet as main K200 works just fine. At a separate location trying to image a few hundred machines, and none of them netboot. I've read here on ITNinja that netboot across different subnets isn't possible, and an RSA is needed. 

I have an RSA already in place for Windows deployment, so I downloaded the K2000 Media Manager to my OSX machine at the remote site, and attempted to create a new netboot image directly to my RSA. It went through the whole process and errored out at the end saying permission denied. The RSA should be up-to-date, have the OSX image synced, and the main netboot image synced. I'm assuming creating a new netboot image directly to the RSA is what's needed, but it's not allowing me.

Any idea as to why it's not letting me create an RSA? I don't want to do all these sudo bless commands, since I have hundreds of iMacs to image - and supposedly an RSA should work.

Answer Summary:
1 Comment   [ + ] Show Comment


  • The RSA is the best way to get around Apple's limitation of bootp traffic not hopping subnets. There is also a tool that Mike Bombich wrote some time ago called Netboot Across Subnets (NBAS) that can also work, but it requires deploying a pkg across Apple Remote Desktop in order to work. The RSA sounds like the best bet for your task.
Please log in to comment

Community Chosen Answer


You do nothing on the RSA but deploy.  All other actions are preformed on the primary k2000 and then you sync that out to the RSA's.  You upload all mac boots and images to k2000 first, check what you want to sync and sync it.

Answered 08/06/2013 by: SMal.tmcc
Red Belt

  • After the sync is complete we hold down the N or Option key to boot to the RSA
  • Thanks for the reply. I figured out that I can't upload netboot images directly to the RSA after talking with support. However, I've synced the OSX image and Netboot image to the RSA, and it's up-to-date. I still can't netboot. I get the flashing globe for a minute or two, then it goes back into OSX like normal. Not sure why it's not working.
  • On the K2000 under settings and Maintenance then Contorl Panel then General Settings there is a place to select the Mac OS X Intel (NetBoot) image. I do not think that was listed in the documentation but needs to be selected. You may have to resync the RSA after selecting that.
    • Thanks - figured that out a couple hours ago with tech support's help. Such a simple fix, but overlooked obviously!
Please log in to comment



Figured it out with tech support help - the RSA's website has an option under network settings to enable Netboot support. So simple....yet couldn't find documentation on it anywhere :)

Answered 08/06/2013 by: sfigg
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity