I am having some issues with packaging this app.

The problem lies with the default open/save location to be My Documents. However in our environment, My DOcuments is mapped to the user's home drive. And it would seem OmniPagePro cannot handle UNC Paths.
Trying to save to a redirected My Documents causes an errror.

Anyways, I am trying to change the default path location, which I have noticed is in a HKCU key as well as a XML file in the APPDATAFOLDER.

However when modifying the msi to create a self healing of that xml file I started to get problems.

Here's what happens:

Whenever a non-admin runs the program it attempts to contact the msi package. An admin does not have this issue.
This is not a case of the admin having access to the msi package however. If installed and then deletiong the msi the problem still exists. Admin runs fine and non-admin tries to access the msi.

However I have used regmon and filemon and pretty much giving full access to the registry and HDD with no success. It does not seems to be a access issue. It just seems that it wants admin access.

Anyone come across something like this?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi emuringer,

Maybe its just me, as I haven't had coffee yet, but I've read this paragraph a few times over and still can't make sense of it:

WHnever a non-admin runs the program it attempts to contact the msi package. A non-admin does not have this issue.
This is not a case of the admin haviong access to the msi package however. If installed and then deletiong the msi the problem still exists. Admin runs fine and non-admin tries to access the msi.


I'm not exactly sure what the problem is. So you run it, it self heals, and causes some sort of problem, something to do with the XML file. Where is the XML file located? Have you had a look in the event viewer?

I assume it works fine for admins? That seems to conflict with what you are saying above A non-admin does not have this issue

Maybe someone else knows what you mean, but if you could clarify the actual problem I might be able to help

:)

Paul
Answered 06/27/2005 by: plangton
Second Degree Blue Belt

Please log in to comment
0
Ahhh my bad.

I meant to say it works fine as an admin.

Here's the actual test I ran.

-copied msi to local machine. Installed while logged on as an admin
-deleted msi package.
-ran application as the installer and works fine.
-log on as a test accoount that has local admin privs....works fine.
-remove local admin privs rights from that test account and ran app....it tries to contact the msi install and fails.

Now considering it worked just fine while it had admin rights I assumed it was a privlages issue. But I literaly gave that test account full access to everything under the sun on that PC without adding it to the local admin group. Still doesnt work.

The actual xml file that I need to change is located in the appdatafolder (c:\documents and settings\username\application data\scansoft\omnipagepro14). Hence the need for the healing, but when I put that healing into the package I get the above problem.
Answered 06/27/2005 by: emuringer
Senior Yellow Belt

Please log in to comment
0
Emuringer,

What points it to the path to the XML file? I'm wondering if, when you isntall it as an Admin, it had a registry reference or something telling it to find the XML file in the Admin's profile. So say your Admin is called Emuringer, then the reg key would be:

c:\documents and settings\emuringer\Application Data\whatever.xml

So when your test user is an admin, it can access that directory. As soon as you take admin rights away, it looses the ability to see in another users profile, so can't find the XML file so tries to self heal. Maybe. Check the event viewer, it will tell you what is triggering the self heal, so that should help.

Other than that, all I can think of is try putting the XML file in the all users profile, it might just work. Though it might not too.

Hope that helps.

Rgds

Paul
Answered 06/27/2005 by: plangton
Second Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity