I have been working getting DssPlayer Pro 5 to install silently. In the new version they give you a tool for creating your own MST. However, I tried many things to get this to work but for some reason it will not pull information from the .mst file. I will post the part of the log file for you guys that I think where it is going wrong. I can post the full log if you would like.

MSI (s) (18:D0) [09:12:59:997]: Looking for file transform: \\bhmps02\DATA\Repository\Softwares\data\dss_player_pro_r5\dssplayer_5_0_0\DssPlayer.mst MSI (s) (18:D0) [09:13:00:017]: File will have security applied from OpCode. MSI (s) (18:D0) [09:13:00:017]: Original transform ==> \\bhmps02\DATA\Repository\Softwares\data\dss_player_pro_r5\dssplayer_5_0_0\DssPlayer.mst MSI (s) (18:D0) [09:13:00:017]: Transform we're running from ==> C:\WINDOWS\Installer\1f33f8.mst MSI (s) (18:D0) [09:13:00:017]: SOFTWARE RESTRICTION POLICY: Verifying transform --> '\\bhmps02\DATA\Repository\Softwares\data\dss_player_pro_r5\dssplayer_5_0_0\DssPlayer.mst' against software restriction policy MSI (s) (18:D0) [09:13:00:017]: Note: 1: 2262 2: DigitalSignature 3: -2147287038 MSI (s) (18:D0) [09:13:00:017]: SOFTWARE RESTRICTION POLICY: \\bhmps02\DATA\Repository\Softwares\data\dss_player_pro_r5\dssplayer_5_0_0\DssPlayer.mst is not digitally signed MSI (s) (18:D0) [09:13:00:027]: SOFTWARE RESTRICTION POLICY: \\bhmps02\DATA\Repository\Softwares\data\dss_player_pro_r5\dssplayer_5_0_0\DssPlayer.mst is permitted to run at the 'unrestricted' authorization level. MSI (s) (18:D0) [09:13:00:027]: Validating transform 'C:\WINDOWS\Installer\1f33f8.mst' with validation bits 0 MSI (s) (18:D0) [09:13:00:027]: Transform 'C:\WINDOWS\Installer\1f33f8.mst' is valid. MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: Patch 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: PatchPackage 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: _Tables 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: _Columns 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: Media 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: File 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: PatchPackage 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: Note: 1: 2262 2: Patch 3: -2147287038 MSI (s) (18:D0) [09:13:00:027]: TRANSFORM: 'PatchPackage' table is missing or empty. No pre-transform fixup necessary. MSI (s) (18:D0) [09:13:00:027]: TRANSFORM: Applying regular transform to database.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Any ideas?

How about using the <% code tags so it possible to read the log?

Can you apply the tranform to the MSI in Orca / InstEd ?

Cheers,
Rob.
Answered 03/11/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Yes I can apply the changes using Orca and I can see where it adds the tables but it just will not work. It could be just Olympus gave out the wrong commands.
Answered 03/11/2009 by: svfusion
Yellow Belt

Please log in to comment
0
I don't know what happened to your log but it's lost all its CRLFs and is still unreadable.

Do a search-and-replace, for 'MSI (S)' replaced with '[CRLF]MSI (S)' and edit your post with the revised content.
Answered 03/12/2009 by: VBScab
Red Belt

Please log in to comment
0
I had a lot of fun getting this to work, and my conclusion was that while the management software will let you create a transform (MST) file, and while this does work as expected when GPO deployment is used, which is how we've previously done this, it does not work from the command line. Whether /t or TRANSFORMS= is used, the transform is ignored.

I got around this by passing the settings as command line switches (these are reasonably well documented in the manual). This works run directly, from a .CMD file, and I've just done a successful test from our KBOX.

The command used was like this for the Dictation module:

[font="courier new"]msiexec /i PATH_TO_FILE\DssPlayer.msi /qn SYSTEM=WORKGROUP LM=license.server.name PORT=80 DCT=INST DM=INST REPOSITORY=Path_to_repository

And for the transcription module:

[font="courier new"]msiexec /i PATH_TO_FILE\DssPlayer.msi /qn SYSTEM=WORKGROUP LM=license.server.name PORT=80 TM=INST REPOSITORY=Path_to_repository

Filling in your own details, of course...
Answered 11/20/2009 by: lesbessant
Yellow Belt

Please log in to comment
0
Whether /t or TRANSFORMS= is used, the transform is ignored. There are really only 2 reasons why a transform would be ignored. One, the machine can't find it and two, there's an error in it.
Answered 11/20/2009 by: VBScab
Red Belt

Please log in to comment
0
ORIGINAL: VBScab
There are really only 2 reasons why a transform would be ignored. One, the machine can't find it and two, there's an error in it.


That makes sense - I suspect it's the latter, as this fails whether transform is referenced by UNC path or when the installation folder is copied to a local C: drive (the transform being in the same location as the MSI either way). The one thing I haven't tested is if the transform created for the AD deployment some time ago differs from the ones created with a newer version of the software.

Anyway, I'm happy enough to have got around the problem!
Answered 11/20/2009 by: lesbessant
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity