I'm trying to roll out office communicator via gpo. I have 2 msi's that I have tested. Package installation fails when assigned. I published the packages so I could get a better idea of errors occuring. the original msi fails with an unspecified fatal error. The other fails and states that the file is not a valid installation package for the product Microsoft Office communicator 2005. Try to find the installation package 'Communicator.msi' in a folder from which you can install Microsoft Office Communicator 2005. This msi has the patch slipstreamed in the msi by msiexec /a Communicator.msi /p Communicator.msp. Here's the verbose log output:

=== Verbose logging started: 3/26/2008 14:07:37 Build type: SHIP UNICODE 3.01.4000.4039 Calling process: \??\C:\WINDOWS\system32\winlogon.exe ===


EDIT: SOLUTION::::::


I have solved the problem. I have found that by simply creating and setting permissions on one key in the registry, Communicator can be deployed via GPO assigned to users.

So here's the skivvy. I created the below script and set it up as a startup script in a gpo that applied to all computers. In the same GPO, I setup the permissions on the registry key to be full control for all users (the install creates one value in the key and that’s it).

Here's the script:

const HKEY_LOCAL_MACHINE = &H80000002

set oReg=GetObject("winmgmts:{impersonationLevel=impersonate}!\\.\root\default:StdRegProv")
strKeyPath = "SOFTWARE\Microsoft\Windows\CurrentVersion\Communicator"
oReg.CreateKey HKEY_LOCAL_MACHINE,strKeyPath


the key to set permissions on is:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Communicator

Hope this helps in the future.

-- Micah Rowland
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

There are no answers at this time
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

Answer this question or Comment on this question for clarity