I wonder if anybody has emcountered the following problem and could suggest a solution..?

We are attempting to install Office Professional Plus 2010 using Group Policy. we have scripted a theoretically silent installation using the Office Customization Tool. However we have found that if we run the installation whilst a user is logged in it works fine, but when assigned to run on startup the "Please wait while setup pepares the necessary files" briefly flashes up and then disppears and the installation stops at that point. It seems on the face of it that the window cannot be opened unless a user is logged in..?

Many thanks.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Assigned or published?

User-targetted or machine-targetted?
Answered 06/23/2011 by: VBScab
Red Belt

Please log in to comment
0
Assigned, in "Computer Configuration" and "User Configuration" in turn. If assigned to "User Configuration", scipt runs when a user logs in, the "please wait" window opens OK, and when it's done it's stuff the installation continues silently in the background, successfully.

However if we assign within "Computer Configuration", script is run during "Startup scripts" before a user logs-in, the "Please wait" window flashes up for a second or so, then vanishes and the installation stops at that point...

We peviosly installed Office 2007 Enterprise with a similar script without encountering this problem, but Office 2010 doesn't want to know so to speak...
Answered 06/23/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
For the cumputer installation, you will need to supress all dialogues because it is attempting to interact with the user's desktop which doesn't exist at the time the installation starts.
Answered 06/23/2011 by: jmaclaurin
Third Degree Blue Belt

Please log in to comment
0
Thank you, how would I go about doing that..?
Answered 06/23/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
Well it depends on what is actually prompting in your script. If its a dialogue added to your script, then start there. If its the office install, then you need to modify the config.xml to look something like this.

<Display Level="None" CompletionNotice="No" SuppressModal="yes" AcceptEula="Yes" NoCancel="Yes" />
Answered 06/23/2011 by: jmaclaurin
Third Degree Blue Belt

Please log in to comment
0
I am using the Office Custimisation Tool th create a .MSP file, and theses are set there. I also tried a Microsoft supplied batch file with these settings in the Config.xml file, but it made no difference I am afraid, the window still opens...
Answered 06/23/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
Then its possible that your calling another config.xml in another directory or the dialoge is in the batch file.

Here is the command we use. Note that we use variables to specify our source directories.
CALL "%SOURCE%\setup.exe" /config "%SOURCE%\Standard.WW\config.xml" =Installs office std
CALL "%SOURCE%\setup.exe" /config "%SOURCERT%\config_AccessRT.xml" =Installs Access

Also, check in the batch file for:

@echo on

echo words to be displayed

if so, change to this.

@echo off

rem echo words to be displayed
Answered 06/23/2011 by: jmaclaurin
Third Degree Blue Belt

Please log in to comment
0
the window still opensIt's a common error to leave the XML in its commented form, as in<!-- <Display Level="None" CompletionNotice="No" SuppressModal="yes" AcceptEula="Yes" NoCancel="Yes" /> --> At a quick glance, it *looks* like you have the correct form. Also remember that you have to use the full path to the XML file in the argument to SETUP.EXE
Answered 06/24/2011 by: VBScab
Red Belt

Please log in to comment
0
Thank you for this.

I have tried "Echo Off" but it made no difference, and we definatly have only the one Config.xml file...

Oh well...
Answered 06/24/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
Thank you again.

The config.xml is not commented out. The real qusetion is why our installation scripts run perfectly when assigned through group Poly to the "User Configuration", but not when assigned to the "Computer Configuragtion"

In other words why willl the "Please Wait" window open when a user lis logged in, but not when no user is logged in..?
Answered 06/24/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
Er...because user-assigned installations don't get triggered until a user logs in.

Actually, do you really want to put your users through the torment of an Office installation while they wait to get on with their work? If there's an existing Office installation, it's going to take at least an hour. You'd be much better off pushing via SCCM or some other deployment mechanism which you can schedule overnight.
Answered 06/24/2011 by: VBScab
Red Belt

Please log in to comment
0
you misunderstand, we don't wish to push when a user is logged in,but the installation will run in that environment, but not at PC starup that is the problem...

SCCM works fine, except that it is too slow...
Answered 06/24/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
I'm guessing that you want that because you have user-level stuff that you want to be installed? Why not use healing for that? Or [shudder] Active Setup?

SCCM slow? Compared to GP? Really?!? LOL
Answered 06/24/2011 by: VBScab
Red Belt

Please log in to comment
0
What we want to do is to install Office 2010 across our network with a GPO that does the installation on computer startup, but we are unable at present to do this because it would appear that when run on computer startup the installer is unable to open the initial "Please wait while setup prepares the necessary files" window, which appears even though "Display Level" is set to none. This did not happen when we rolled out Office 2007, but it is happening, at least on our network, when installing office 2010.

What we are looking for is a way to get round this problem, so we can install Office 2010 on computer startup.

We have only recently implemented SCCM 2007, but our initial experience is that it takes a long while for Advertisments to reach the PC's, also that there appear to many points of potential failuere within the installation process. This being so we are reluctant to try a deployment to 2,500 PC's and laptops, as keeping track of the potential failures may be difficult to say the least...
Answered 06/24/2011 by: Dave.Minty
Senior Yellow Belt

Please log in to comment
0
There are two ways you can suppress the display messages but it depends which you are using. If you used the OCT to make an MSP file it'll be under Setup as the Licensing and user interface settings. The other is if you chose to use the XML config file which sounds like what you opted for. As VBScab noted earlier, take a close look at your XML code and be certain you don't have any lines commented out or missed a syntax error. Have someone else take a look at your work. A second set of eyes can do wonders for a hangup like this.
Answered 06/24/2011 by: Helpy
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity