Hello,

I precede this by saying I am very new at Kace so please bear with me. I am attempting a package deployment of Office 2010. I have:

1. Run the Setup /Admin, made my config changes and saved the MSP file to both the root of the executables and in the Updates folder (as some posts suggested that).
2. Zipped it all up not from the folder level, but the root files level.
3. Verified the Zip opens on several computers
4. Created the distribution with several different command lines:
setup.exe /adminfile custom.msp
"setup.exe" /adminfile "custom.msp"
"setup.exe /adminfile custom.msp"
"setup.exe" /adminfile "Updates\custom.msp"
5. I have applied the distribution to a single test computer with the latest agent.

When I monitor the event log of the target computer, upon attempt to do the deployment, I get an Error Event for KBOX Client with this message:

Exception Type: System Exception
Message: Package download failure, or missing 'full command' if MI is a .zip file
TargetSite: NULL
HelpLink: NULL
Source: NULL

Any help would be welcome and appreciated.

Thanks

Kev
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Sounds like you are running it as Use default. Under managed installed make sure you click the radial button that says "Configure Manually" and then put in your "setup.exe" /admin "custom.msp". You may or may not need the quotes.
Answered 06/17/2011 by: nshah
Red Belt

Please log in to comment
0
I am using the Configure Manually, the current iteration of the command line is:

"setup.exe" /adminfile "Updates\custom.msp"
Answered 06/17/2011 by: KBUNE
Senior Yellow Belt

Please log in to comment
0
I have a deployment for Office 2007 the same way you have your 2010.

My command line reads:
"setup.exe" /adminfile "silent.msp"

Two things to look at. Try putting the .msp file in the same directory as setup.exe and make sure the "Don't Prepend msiexec.exe:" is checked. This will cause an invalid command to be issued
Answered 06/17/2011 by: lgeier
Senior Yellow Belt

Please log in to comment
0
No joy.
Answered 06/17/2011 by: KBUNE
Senior Yellow Belt

Please log in to comment
0
Make sure the setup.exe is at the root of the zip file, as well as all the other files. The MSP should be placed in the Updates directory. Try a manual command line "setup.exe" It will detect and apply the MSP found in the Updates directory - no need to add to the command line.
Answered 06/17/2011 by: mlathrop
Fifth Degree Brown Belt

Please log in to comment
0
I believe that the install process is the same as Office 2007

http://www.kace.com/support/kb/index.php?action=artikel&cat=4&id=992&artlang=en
Answered 06/17/2011 by: KevinG
Purple Belt

Please log in to comment
0
Two notes:

1. .MSP files, whether created by the Office Customization Wizard or something else (like a service pack), do not have to be on the command line, as long as you put them in the Updates subdirectory of the main Office directory. Any .msp in that Updates folder is run automatically, in alphabetical order. So, if you have two .MSP files in the Updates subdirectory, you might rename them 1Custom.msp and 2ServicePack.msp, then just run setup.exe from the parent directory. By leaving these off the command line, you may solve the referencing problem.

2. When Windows installers use auxiliary files, I often find I have to use a full path name, especially with KBOX-based installs. Sometimes it can be a relative path name like ..\1file.txt, and sometimes it needs to be an absolute path name like "$(KACE_DEPENDENCY_DIR)\1file.txt". With Office 2010, I use the /config parameter from a batch file, and if I'm remembering correctly, I used a relative path name, something like this:
setup.exe /config ProPlus.WW\config.xml
If you need to use the KACE variables inside a batch file, you can pass them in like this:
MI command configured manually: batch.bat "$(KACE_DEPENDENCY_DIR)"
In the batch.bat file: %1\setup.exe /config %1\ProPlus.WW\config.xml
(Though the quotation marks in the fully resolved path name are in the wrong place, this still seems to work.) Sande
Answered 06/18/2011 by: snissen
Fourth Degree Green Belt

Please log in to comment
1
for what it's worth this is how we got it to run. The config.xml file was placed in the root of the zip file along with the setup.exe to to get it to run.

Answered 06/20/2011 by: craig.thatcher
Orange Belt

  • Thanks, Craig. Those 2 config.xml tips helped my to get Office 2010 deployed
Please log in to comment
Answer this question or Comment on this question for clarity