I have used the Office 2007 Pro Plus admin setup to create an .msp file for a silent Office install to deploy with SCCM. That works great. But after I install Office, when I launch an Office app for the first time I get prompted to set privacy options and to sign up for Microsoft Update.

I searched and found an article that suggested I disable "Enable Customer Experience Improvement" and "Automatically Receive Small Updates" in the admin setup under Features- Modify User Settings- Microsoft Office 2007 System- Privacy- Trust Center. I've done that and I updated my package source, but I still get the prompts...

Is there another way to turn these prompts off? We patch systems with WSUS and I don't want my users getting confused by that prompt to receive auto-updates.

Thanks!!!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You'll find answers to these questions in the Package KB here on appdeploy.

The following notes are taken from the above article :


To remove privacy option popup, set the following values in the registry:

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\User Settings\Product code]

"Count"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\General]
"Authorized"=dword:00009904
"ShownOptIn"=dword:00000001



The registry entries work great to get rid of the Privacy Options when the application is first opened, but to get rid of the option to go to Office Updates at the end of the install, you must go into the msp file, go to the Modify Setup properties section, and add a property named HIDEUPDATEUI with the value set to True.



Regards,

Spartacus
Answered 04/06/2010 by: spartacus
Black Belt

Please log in to comment
0
Thanks Spartacus,

I found these in the KB but they are not working for me.

I have added all 3 registry keys and added the HIDEUPDATEUI property under "Modify Setup Properties" but I still see both prompts the first time the user launches the app after install. All of my other customizations in the MSP work perfectly.

I have tried scrapping my .msp and creating a new one, but the new one does the same thing too. I am installing on a mix of Windows XP and Windows 7 (in case that matters). My test boxes are all Windows 7.

Does anybody have any suggestions?
Answered 04/06/2010 by: HisboyElroy
Yellow Belt

Please log in to comment
0
Just a couple of questions :

1) Have you checked that the registry settings mentioned in the KB article are being propagated to each user after they have launched an Office application for the first time ? (Launch regedit using the user account and navigate to the HKEY_CURRENT_USER\Software\Microsoft\Office\12.0 subkeys outlined in my earlier reply in order to check this.

2) The KB article mentions the key

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\User Settings\Product code

however you need to make sure you substituted the actual product code (GUID) for Office 2007 Pro Plus in place of the string 'Product code' in this key name, have you done this ?

Regards,

Spartacus
Answered 04/07/2010 by: spartacus
Black Belt

Please log in to comment
0
OK, my bad...

I created a registry key called "ShowOptIn" instead of "ShownOptIn" with a value of 00000001

Should've cut and pasted... Sorry about that.

Thanks for your help Spartacus, it seems to be working now.
Answered 04/07/2010 by: HisboyElroy
Yellow Belt

Please log in to comment
0
glad it worked for you, but you did something wrong because i packaged several 02k7 apps and never had to do a reg hack outside of the admin setup to disable that. look for updates to the admin toolkit on microsoft office updates
Answered 04/08/2010 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity