I'm having an issue deploying Office 2007 as an upgrade to Office 2003. The installer forces a reboot after the installation and I cannot find a way to repress it. No prompting at all - just reboots the system (XP SP2) . I've edited the config.xml as follows without success:
<!-- <Setting Id="SETUP_REBOOT" Value="NEVER" /> -->
This file is located in the same folder as the setup.exe and .msp that I am using. Is there another way to supress the reboot?
Can I use this portion of the config.xml :
<!-- <Command Path="msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->
to pass REBOOT=""ReallySuppress" into the main MSI? If so, what msi do I pass it to?
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Just in case, but did you check the Appdeploy page:

Just in case, did you take away the commented <!-- -->
So the line looks like:
<Setting Id="SETUP_REBOOT" Value="NEVER" />
Answered 06/25/2009 by: tron2ole
Third Degree Blue Belt

Please log in to comment
The <Command> element is used to run a separate MSI e.g. to install a pre-requisite.
Answered 06/26/2009 by: VBScab
Red Belt

Please log in to comment
Recently i did the same application. My client was also having the same problem.

with following switch,

office 2007setup.exe /admin open the existing msp file of office 2007 or if you have not created it, just create it, because all the customisations, you will have to do with this, msp file.
In this msp file set property, REBOOT=reallysuppress, as well as you can set settings to uninstall previous versions of office as well.
Answered 06/27/2009 by: suchi.jigar
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity