Anyone know how to modify the desktop right click menu for Office 2007 item ?

Our standard extension is non-Docx. So I had to modify the installation to save, by default, into .doc, .xls format. But, when you use the desktop right click menu to create a new Excel or Word, it create a .docx, .xlsx document.

Is there a way to change this ?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Eric,

I believe this is linked to the HKCR\<.your extension>\ShellNew registry keys.
Have a look here

Good luck [;)]
Answered 04/23/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
Didn't help. This key seems to refers only to the Open with function

I found this Key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew

Document Microsoft Office Word=hex:00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
44,00,6f,00,63,00,75,00,6d,00,65,00,6e,00,74,00,20,00,4d,00,69,00,63,00,72,\
00,6f,00,73,00,6f,00,66,00,74,00,20,00,4f,00,66,00,66,00,69,00,63,00,65,00,\
20,00,57,00,6f,00,72,00,64,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,2e,00,64,00,6f,00,63,00,78,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,57,00,\
6f,00,72,00,64,00,2e,00,44,00,6f,00,63,00,75,00,6d,00,65,00,6e,00,74,00,2e,\
00,31,00,32,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,ff,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
00,00,00,00,00,00,00,00,00,00,00,00,00,00



I change 78 for 00 to remove the x (in .docx). It works for the first time but I received an error message and the key revert to his original value 78. I will continue my research...
Answered 04/23/2010 by: darkfang
Blue Belt

Please log in to comment
0
No, you need to futz with HKCR.

Presumably you want to use .DOC instead of .DOCX? Start at HKCR\.DOC\ShellNew. I don't know how to structure the rest of it but I'm sure a bit of digging in MSDN will turn something up.

EDIT:
My post in the 'Off Topic' forum is most apposite, as I missed Pieter's link.
Answered 04/23/2010 by: VBScab
Red Belt

Please log in to comment
0
Thanks Pieter and VBScab

I deleted HKCR\.doc, rename HKCR\.docx to HKCR\.doc but I still have an error message when I right click, New, Microsoft Office Word Document. It happen only for 1 time but i have my .doc document. I will do a before-after capture and look what happen.
Answered 04/23/2010 by: darkfang
Blue Belt

Please log in to comment
0
I think this is related to CLSID's so you need to tweak around with CLSID's to make it work as per your requirement
Answered 04/23/2010 by: mekaywe
Brown Belt

Please log in to comment
0
Ummmmmmmmmmmm.....sorry, no, it's not connected in the slightest way with CLSIDs
Answered 04/23/2010 by: VBScab
Red Belt

Please log in to comment
0
Sorry for the configuration mentioned by me in my earlier post. There was some problem with Office 2007 which I installed for testing.

I have rechecked and found that below keys are required for desired configuration
1. Remove the string "NullFile"="" from below registry
[HKEY_CLASSES_ROOT\.docx\Word.Document.12\ShellNew]
This will remove the default context menu item for .docx.
Instead add the string "NullFile"="" under
[HKEY_CLASSES_ROOT\.doc\Word.Document.8\ShellNew]
This will create a rightclick/context menu item for .doc.
Similarly .xls,.ppt extensions can be taken care.
Wait for few minutes to get the context menu items refreshed.

2.If you want the default save as option to be .doc instead of .docx ,please set the below key
[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options]
"DefaultFormat"="Doc"
Answered 04/25/2010 by: Yankir
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity