Hi!

is any one had the same error after instaling some package, after launching the LabX media i get an error that cand finde one dll file,i dont know why it wont install it, cose i have it in my mst, and after i put it manualy in program files i get an error:
No DLEdit object! Reinstall LabX titration. HRESULT = 80004002 FACILITY = FACILITY_NULL E_NOINTERFACE No such interface supported

pls help
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Assuming a manual installation does work correctly...

Did you correctly register your DLL? Try running Regsvr32.exe /i <path to your DLL> and try again.
If that works check your MSI to make sure the registration is done correctly

PJ
Answered 09/30/2009 by: pjgeutjens
Red Belt

Please log in to comment
0
i tried that, saying that this file can not be registered, and original msi instalation works correctly
Answered 09/30/2009 by: lanselots
Fourth Degree Brown Belt

Please log in to comment
0
Ok, first of all try the regsvr command without /i

If still nothing open your MST and check the following:

component that contains the DLL, does it have conditions, is it linked to a Feature
Are there conditions on the Feature that contains the component
Is the Destination Path for the component correct
Is the file set to selfreg or not?

Also, run your installation with full logging and look what you find about the component and the file

If nothing else helps run a procmon on a manual install and your package install and compare the 2
Answered 09/30/2009 by: pjgeutjens
Red Belt

Please log in to comment
0
Did you add the file to the transform or was it already present in the MSI?

If the former and the MSI is a vendor MSI and you created a transform against it, it will almost certainly have createdan external CAB file to contain the file. In that case, did you include the CAB with your MSI/MST?
Answered 09/30/2009 by: VBScab
Red Belt

Please log in to comment
0
yes there is a cab file,and in that cab file is thet dll, and it is installing that cab file with msi, but any way it dont shows under program files, and i dont know way :(
Answered 09/30/2009 by: lanselots
Fourth Degree Brown Belt

Please log in to comment
0
and for that dll there is no conditions, it is futured for component

i also chek that install level was 50 for that feature, and i changed it to 1, because in property it was 40, but any way it wont install
Answered 09/30/2009 by: lanselots
Fourth Degree Brown Belt

Please log in to comment
0
Does the CAB file appear in the Media table and is the file sequence number correct?

As a fail-safe, I'd suggest removing the file from your authoring tool's UI (you're a WPS user, right?), add it back then re-compile.
Answered 09/30/2009 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity