I have another problem related to shortcuts. I have no idea why shortcuts cause me so much problems.

I have an app called GlobalVision. The desktop shortcut points to the default install root C:\program Files\Trayport

I want to change the Target of this desktop shortcut so it points to a network share path, like P:\Trayport.

I imagine I can use MS ORCA to change the shortcuts target path. I tried specifying the new path in the Arguments under the shortcuts table, but it didn't work.

Can someone give the newb a tip...
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You need to use the WkDir field in the shortcut table. there have been other examples on appdeploy pls use the search
Answered 10/22/2010 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
Thanks for this. Sorry to revive this old thread,

This is what I got so far

Shortcut Properties
TARGET LOCATION
TARGET = TRAYPORT GLOBALVISION (FIELD IS DISABLED)
START IN = P:\Trayport


I got the value changed "START IN" to what I wanted by doing as you suggested. However I also require to change the value of the shortcut "TARGET" Right now it says "TRAYPORT GLOBALVISION" and is grayed out -I need to replace this with "C:\Program Files\Trayport\Globalvision\Vision8.exe-filename P:\Trayport"

I believe the fact that the default is grayed out means that its a advertised shortcut, so I tried disabling advertised shortcuts using "DISABLEADVTSHORTCUTS=1" in the property page (using ORCA) and replacing it with a new property but this didn't work.

I am sorry to be a nag, but I have spent 3 days trying to figure this out with little progress and I am out of ideas.

Thanks very much for your help.
Answered 10/29/2010 by: mmarsh
Orange Senior Belt

Please log in to comment
0
Sounds like you are just trying to add an argument to your shortcut?

Simply add the following in the Arguments column:

-filename P:\Trayport

Best practice is to create a property in the property table like this:

SHORTCUTARG=-filename P:\Trayport

Then in the arguments column for the Shortcut Table you do [SHORTCUTARG].

This way you can change the shortcut argument later by setting the public property (SHORTCUTARG) during the installation.

Download the greatest software in the universe to make these changes:

http://www.instedit.com/
Answered 10/29/2010 by: dreyer
Purple Belt

Please log in to comment
0
Thanks for your reply Dreyer

I tried that it didn't work. In the SHORTCUT PROPERTIES under TARGET its still saying "TRAYPORT GLOBALVISION" (and its grayed out). The "find target" and "change icon" buttons are likewise disabled. Its as if the system is not allowing me to make ANY changes to that field.

I managed to do it once accidentally, but I used the wrong value and when I redid I couldn't recreate it.
Answered 10/29/2010 by: mmarsh
Orange Senior Belt

Please log in to comment
0
delete the shortcut and start again using the tips people have given you!

then go and by the definitive guide to windows installer book.....
Answered 10/29/2010 by: timmsie
Fourth Degree Brown Belt

Please log in to comment
0
ORIGINAL: mmarsh

Thanks for your reply Dreyer

I tried that it didn't work. In the SHORTCUT PROPERTIES under TARGET its still saying "TRAYPORT GLOBALVISION" (and its grayed out). The "find target" and "change icon" buttons are likewise disabled. Its as if the system is not allowing me to make ANY changes to that field.

I managed to do it once accidentally, but I used the wrong value and when I redid I couldn't recreate it.



That's because it's an advertised shortcut. But why does it matter? The shortcut will still work as expected if everything else is setup correctly in the .msi.

If you don't want an advertised shortcut for other reasons you need to point to the file you want to launch in the Target column instead of the feature.

Perhaps you should hire a packager.
Answered 10/29/2010 by: dreyer
Purple Belt

Please log in to comment
0
Solved!

Thanks everyone for their help. I figured it out. What I did was to convert it into a non-advertised shortcut and added the -file p:\trayport into the arguements column.

Many Thanks!
Answered 11/02/2010 by: mmarsh
Orange Senior Belt

Please log in to comment
0
you also could use [WkDir] in the START IN = P:\Trayport instead of hard coding it. you're right, Advertised shortcuts don't have all the options to edit so good catch on that.
Answered 11/02/2010 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity