I have been getting an error described below everytime I am trying to install an MSI created by the "Setup Capture" (in Wise Package Studio 8.0) regardless of the application, so, I request someone to tell me if I am doing anything wrong or is it the problem with VMware itself that might has an erronious snapshot that everytime it is capturing some erronious file while making the WSI file, which is producing an erronious MSI. The problem is described as below:

A window is popping up says:

"Files in Use
Some files that need to be updated are currently in use
The following applications are using files that need to be updated by this setup
Windows Explorer
"radio button1" - Automatically close all applications and attempt to restart them after setup is complete
"radio button2" - Do not close applications.(A reboot will be required)
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi ,

Its simple you have captured the windows explorer folder with your msi.Windows explorer no needed for your application so just delete the widnows explorer from your MSI.Then your application works fine without error.

So edit your MSI using wise package studio 8 and delete the widnows explorer from files and then install your application.

Do let me if its works for you.

Thanks
Answered 03/06/2012 by: dhanraj
Senior Yellow Belt

Please log in to comment
0
Hi,

To delete explorer folder using wise package studio follow these steps :

(1) Edit your MSI using wise package studio.

(2) Go to files tab.

(3) Click windows and then click profiles and then local settings and then click microsoft .

(4) Now you will see explorer folder ,delete the explorer and compile your MSI.

(5) Now install your MSI it will install witthout error.

Please let me if its work for you.

Thanks
Answered 03/06/2012 by: dhanraj
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: dhanraj

Hi,

To delete explorer folder using wise package studio follow these steps :

(1) Edit your MSI using wise package studio.

(2) Go to files tab.

(3) Click windows and then click profiles and then local settings and then click microsoft .

(4) Now you will see explorer folder ,delete the explorer and compile your MSI.

(5) Now install your MSI it will install witthout error.

Please let me if its work for you.

Thanks





Amazing stuff,Thanks so much for this!This is very useful post for me. This will absolutely going to help me in my projects .

-----------------------------------------------------------------------------
[url=http://www.dressale.com/wedding-dresses-mermaidtrumpet-wedding-dresses-c-2_3_25.html]Trumpet Wedding Dresses[/url]|[url=http://www.dressale.com/wedding-dresses-new-style-wedding-dresses-c-2_3_18.html]New Style Wedding Dresses[/url]|[url=http://www.dressale.com/wedding-dresses-sheathcolumn-wedding-dresses-c-2_3_23.html]Column Wedding Dresses[/url]
Answered 03/07/2012 by: zhuo1005
Yellow Belt

Please log in to comment
0
To avoid have to perform the above each and every time, why not just add it to the Global Exclusion list?
Answered 03/07/2012 by: andemats
Second Degree Black Belt

Please log in to comment
0
Thanks a lot Guys... it was a great help ... it did work ... but now I am having a weird problem with an application as below:



I have made an MSI and installed it, then tried to test it from test machine (without admin privilege), and whenver I was trying to launch the application in test machine a window was popping up and saying "Failed to update the system registry. Please try using REGEDIT." I thought a .ocx file was failing to register itself, so, I did manual registration using VBS, also changed the .ocx file's self-registration from "Do not register" to " Unordered (normal Windows Installer behavior)" in Wise Package Studio 8.0. But still the same message kept coming, then I thought might be permission issue, so, gave permission to that particular file, but nothing changed the scenario. So, Could you help on this occasion.
Answered 03/07/2012 by: aridutt007
Blue Belt

Please log in to comment
0
it is possible that the application itself is trying to write to the registry at startup. Do what is called a 'gap capture' by

1) installing the application
2) logging in with an admin user
3) starting a capture
4) running the application for the first time
5) stop capture

Have a look through the resulting capture to see if anything is getting added to the registry (in HKLM or HKEY_USERS\.Default probably), then add this to your MSI.

Kr,
PJ
Answered 03/07/2012 by: pjgeutjens
Red Belt

Please log in to comment
0
Hi pjgertjens,

I always do that, revert my machine to a clean state then capture it, which means the application is getting installed for the first time (at the time of capturing), still I was getting the same problem everytime I was doing
Answered 03/07/2012 by: aridutt007
Blue Belt

Please log in to comment
0
Hi andemats,
Thanks for letting me know that, but as I have already mentioned that I am new to packaging, so, could you please explain how to do that Global Exclusion list.
Answered 03/07/2012 by: aridutt007
Blue Belt

Please log in to comment
0
I always do that, revert my machine to a clean state then capture it, which means the application is getting installed for the first time (at the time of capturing), still I was getting the same problem everytime I was doing

what I meant was not the initial capture for the package. It's a capture after you install the package (not the original application) on a clean machine that only detects what changes when you run the application the first time with admin credentials (not when you install it). It is possible some extra entries are written to the registry when the application starts up for the first time and a restricted user does not have the rights to do this.

FYI this is only relevant if you're getting the error you mentioned only when running with a restricted user, and not when starting the application as admin.

PJ
Answered 03/07/2012 by: pjgeutjens
Red Belt

Please log in to comment
0
how to do that Global Exclusion list.Really hard...in the series of dialogs which appear after the capture is complete, you will see the list of files. Select the file(s) you want to exclude and then click the 'Exclude' or 'Exclude Globally' button.

As a last resort, of course, you could always revert to hitting F1 or indeed reading the documentation which is supplied with the product.
Answered 03/07/2012 by: VBScab
Red Belt

Please log in to comment
0
Hi aridutt007,

My understanding is when you launch your application using admin its working fine,But same when you try to launch using user its throwing error.

Its seems permission issue in registry.So please let me know what application name you are working now ?

I think process monitor tool may help you to find the file permissions or registry issues.

Thanks
Answered 03/07/2012 by: dhanraj
Senior Yellow Belt

Please log in to comment
0
Hi pjgeutjens, it took me a little longer time to understand what you were suggesting, I am going to give it a shot and will post what is happening, Thanks a lot for your help.


ORIGINAL: pjgeutjens

it is possible that the application itself is trying to write to the registry at startup. Do what is called a 'gap capture' by

1) installing the application
2) logging in with an admin user
3) starting a capture
4) running the application for the first time
5) stop capture

Have a look through the resulting capture to see if anything is getting added to the registry (in HKLM or HKEY_USERS\.Default probably), then add this to your MSI.

Kr,
PJ
Answered 03/08/2012 by: aridutt007
Blue Belt

Please log in to comment
0
yeah u r correct, the application name is Check Vision Inquiry 7, and I don't know why but where I am working, I can't install ProcMon on test machine, so, there is no chance to capture what is exactly happening on the test machine. And yeah I have already tried giving the file permission but it did not work either. There was only one file getting created under C:\Program Files, so there is no chance missing any file, I gave permission to that particular file and I believe it inherited to all his children the same. And if you talk about registry issues, as I am very new to packaging, I am little sluggish understanding quickly which registry causing the problem, but I assumed that a particular .ocx file is not getting registered, so, I did even try to install it manually from cmd and vbs both, but all went in vain.


ORIGINAL: dhanraj

Hi aridutt007,

My understanding is when you launch your application using admin its working fine,But same when you try to launch using user its throwing error.

Its seems permission issue in registry.So please let me know what application name you are working now ?

I think process monitor tool may help you to find the file permissions or registry issues.

Thanks

Answered 03/08/2012 by: aridutt007
Blue Belt

Please log in to comment
0
ORIGINAL: aridutt007

and I don't know why but where I am working, I can't install ProcMon on test machine

ORIGINAL: dhanraj

No need to install it, it's just an exe file you run.
You might, however, need to run it as administrator.
Answered 03/08/2012 by: andemats
Second Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity