Hello,

I made a package for a company that contains an entry in the .net Framework security within the installation expert (Wise) to update the security.config file.

All works great in our test environment also for a standard user account.

But at the client their systems the package only installs with an admin account, with a standard user account there is an error and the package does a rollback.

This is the entry in the installer log file:
--------------------------------------------------------------------------------------
CustomActionSchedule(Action=WiseDotNetSec,ActionType=3073,Source=BinaryData,Target=WiseDotNetSec,CustomActionData=v2.0.50727WiseDotNetSec)
MSI (s) (C4:F8) [13:40:08:449]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSI112.tmp, Entrypoint: WiseDotNetSec
MSI (s) (C4:F4) [13:40:08:449]: Generating random cookie.
MSI (s) (C4:F4) [13:40:08:465]: Created Custom Action Server with PID 1208 (0x4B8).
MSI (s) (C4:D4) [13:40:08:527]: Running as a service.
MSI (s) (C4:D4) [13:40:08:527]: Hello, I'm your 32bit Elevated custom action server.
Action 13:40:08: WiseDotNetSec. Updating .NET Framework Security...
WiseDotNetSec: for version "v2.0.50727"
Action ended 13:40:08: InstallFinalize. Return value 3.
----------------------------------------------------------------------------------------------

Does anyone know what the problem can be? is there a domein policy or whatever that prevents setting .net security??

Thanks,
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Why would you expect a user with ordinary user privileges to be able to install anything?
Answered 08/27/2009 by: VBScab
Red Belt

Please log in to comment
0
The application is deployed with GPO, so elevated rights for the user..
Answered 08/27/2009 by: netloony
Senior Yellow Belt

Please log in to comment
0
I suspect, therefore, that the Custom Action concerned has been set to execute with user rights and requires rights which vanilla users do not have.

Change it to execute in System context.
Answered 08/30/2009 by: VBScab
Red Belt

Please log in to comment
0
Could you turn on the Windows Installer Debug policy (give it a value of 7) to get some more info.

The execution looks good;
ActionType: 3073 = binary DLL, deferred execution, no impersonate
Answered 08/31/2009 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity