Hi,

I have a request for Nero 8. This request is to create a mst for the Nero.msi.
User requires only 4 features which are Nero StartSmart, nero Burning Rom, Nero CoverDesigner and tools.

We have created .mst and it is working fine for administrators. However for users i am getting error while lauching nero shortcuts "Please ask your system administrator to give you permission to write CDs/DVDs. This can be done using the control panel application 'Nero Burn Rights'. the tool is already installed on this PC."

I am getting this error inspite of selecting everybody in the Nero Burn Rights shortcut.
I tried giving permission to the following keys which was shown as access denied in regmon. HKEY_LOCAL_MACHINE\SOFTWARE\Nero, HKEY_LOCAL_MACHINE\SOFTWARE\Ahead,HKEY_CLASSES_ROOT\BCGPOleAcc.BCGPPopupMenuAcc2,HKEY_CLASSES_ROOT\CLSID\{D4082021-53DE-4F13-8334-7D5D70D50EC1}.

when i checked filemon it shows access denied for shell32.dll.

did anyone faced this kind of issue? If so would it be possible to share with us.

Many Thanks.
Regards
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Change the "allocatecdroms" (REG_SZ) registry entry to value 1 under HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Answered 06/18/2008 by: AngelD
Red Belt

Please log in to comment
0
ORIGINAL: anitha_accen
I tried giving permission to the following keys which was shown as access denied in regmon. HKEY_LOCAL_MACHINE\SOFTWARE\Nero, HKEY_LOCAL_MACHINE\SOFTWARE\Ahead,HKEY_CLASSES_ROOT\BCGPOleAcc.BCGPPopupMenuAcc2,HKEY_CLASSES_ROOT\CLSID\{D4082021-53DE-4F13-8334-7D5D70D50EC1}.

As well as following Kim's advice, keep the permissions you've set for these keys, as Nero still requires write access there.
Answered 06/19/2008 by: VBScab
Red Belt

Please log in to comment
0
Thanks AngelID and VBScab. Application is working fine after giving permission to the reg keys and changing the allocatedroms value to 1.

Many Thanks.
Answered 06/19/2008 by: anitha_accen
Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity