For quite some time (from time to time, heh) I tried to create a valid package destribution of Nero 10, to install only Burning Rom application. As you might know, Nero Platinium source contains so much cr..stuff and I don´t want that all to end up to every machine.

Nero 10 source has setup.exe (which supports silent switches), setup.ini, prerequirements even for Windows 7, and every component of Nero is as .msi file.

If I just set setup.exe to run silently, it offcource will install everything and run fine.
I also tried to create several programs to install all prerequirements silently, and then run only burningrom.msi but then program won´t start. I don´t remember exact error message, but it will complain something about missin component (what a supprise, heh).

So, does anyone have experience of packaging Nero 10?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I've not done 10, but there is a lot of information in the 9 knowledge base that may still apply:

http://itninja.com/link/sql-server-books-online---performing-an-unattended-installation9

Have a go and see if it's helpful
Answered 04/08/2011 by: timmsie
Fourth Degree Brown Belt

Please log in to comment
0
ORIGINAL: yannara
I also tried to create several programs to install all prerequirements silently, and then run only burningrom.msi but then program won´t start. I don´t remember exact error message, but it will complain something about missin component (what a supprise, heh).


Yes, out of the several .MSI files available in the Nero 10 source; if required only 'BurningRom.msi' can be run as a standalone install. I think, there must be some issue with the pre-reqs. Also, a REBOOT is required after the pre-reqs install.
Reboot Validator - Have you seen it while installing through setup.exe ??
Answered 04/08/2011 by: WiseAppPackager
Purple Belt

Please log in to comment
0
ORIGINAL: WiseAppPackager
Yes, out of the several .MSI files available in the Nero 10 source; if required only 'BurningRom.msi' can be run as a standalone install. I think, there must be some issue with the pre-reqs. Also, a REBOOT is required after the pre-reqs install.
Reboot Validator - Have you seen it while installing through setup.exe ??


I tried that, that I installed manually all prerequirements and only Burning Rom.msi, after that is still crying about lack of some component. I believe, that the lack is something to do with Nero itself, not prerequirements. Also, there are steps when computer restarts before installing Burning Rom.msi.
Answered 04/08/2011 by: yannara
Blue Belt

Please log in to comment
0
By the way, in Nero 10, the deployment has changed. I saw a forum of Nero, where manufactor replayed himself, that install commands in Nero 9 and earlier versios are not suitable with 10. For mass deployment, you need to have a volume package.
Answered 04/09/2011 by: yannara
Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity