We are running version 3.6.98680 of the K2000 appliance.  I am attempting to get multicast working in our environment.  I have multiple Windows 8 and 8.1 WIM images that I can successfully deploy as unicast jobs, but when I create a multicast test, they boot into the KBE and get as far as the "apply image" task.  This task fails and then the actual deployment performs a few other tasks since it is set to continue on in the event of a task failure. 

When this first happened, after trying a few different images, etc, I started reading around on itninja and elsewhere and thought maybe this was a network issue (PGM).  I sent everything I could find to our network manager and had him make the necessary changes on one vlan for testing.  After he enabled PGM, I tried again and received the same results.

Any thoughts or ideas on what could be the issue or where to look for what exactly is causing multicast to fail?


5 Comments   [ + ] Show Comments

Comments

  • try downloading the k2 advisor under the tools tab. see if detects any problems. that error is temp_system keyset is missing since the wim never deployed.
  • one test to try to see if it is the network, put some machines on the same vlan as the server and see if that works. if that fails then use a switch and put the server and machines on the same switch. this will tell you if the problem is the kbox or the network
  • when we had this problem back in zenworks days it was due to IGMP not being setup properly
    • I have downloaded the K2 advisor but when I run the installer it simply opens the readme.txt. Is it not supported on Windows 8.1?

      I thought K2000 multicast used PGM and not IGMP? Either way, I had sent the information I could find on the network configuration necessary to support multicasting with the K2000 to our network manager. He made the changes and when I attempting again, I received the same result. It fails at "applying wim image".
      • tell it to pause on errors and look at the task xml file see what the call is for that on a machine and try to run it from a command window by hand and see if you get anymore info of why it failed.

        The k2000 does use pgm, just stated that as an example of why the network could be the problem from past experience. You just need to narrow the cause of this, it can be a few things. I would still do the couple of tests I mentioned before to see which one it is the network vs the kbox so you know where to trouble shoot next and narrow the problem down.
      • I am leaning to the network when I read things like this
        http://www.experts-exchange.com/Hardware/Networking_Hardware/Switches/Q_24581974.html
      • The following task failed.
        Task ID: 30
        Task name: Apply Image
        Return code: 4294967295
        Error description: Unknown error
      • Was there an answer there on Experts-Exchange? In my experience, they are only using your own searches against you to try and trick people into subscribing. If there is a real, honest answer there I would gladly have my supervisor dust off the company credit card.
      • wow that is weird, I can go to that via my google search and read it but the same link I posted wants money.

        his problem came down to the TTL was only 1 and you need a higher value to cross vlans with multicasting and he discovered that his router supported pgm but the switches did not with the firmware he was running.

        He wrote:
        The "IP PGM router" command which I have mentioned in the core switch is not available in my Edge switc, so I guess it is this command that is needed on the Edge switch for the PGM protocol to work across VLAN.

        so do not waste money on this site.
      • Thank you for the information, I will pass this on to our network manager to see if there is something there.

        Have you seen this error before?

        Task ID: 30
        Task name: Apply Image
        Return code: 4294967295
        Error description: Unknown error
  • Here is some additional information on Task 30:

    <Task ID="30">
    <Name>Apply Image</Name>
    <WorkingDirectory>Y:\hta\amd64</WorkingDirectory>
    <CommandLine><![CDATA[Y:\scripts\system_image_wim_deploy_179.bat]]></CommandLine>
    <Parameters></Parameters>
    <PostTaskAction>None</PostTaskAction>
    <KACETaskType>BAT Script</KACETaskType>
    <FileType>Batch</FileType>
    <Type>PR</Type>
    <Guid>1539b53c62154e</Guid>
    </Task>
  • That sounds like something in the multicast script is failing to see the kbox, you can open a command window from the recovery options on the main screen and go to y:\scripts and type the bat name to see if it runs and see if you get better details on the error.

    Have you tried to bypass the network and test on a switch that the kbox is on? This will tell you if it is the network or kbox is the problem. You can multicast to just 2 machines to test.

    If putting the targets on the same switch as the kbox does not work and you have not already done so, try to create new automated boot action that unicasts to 2 machines and
    see if if works.

    So far I have only run my multicast tests in my test env so I had everything on the same switch. I abandoned the idea of using multicasting since I can get better thru put using my method of storing the wims externally and imaging from one kbox but multiple repositories for the wim file.

    http://www.itninja.com/blog/view/wim-storage-freeing-up-space-on-your-k2000-if-you-are-using-wims-k2000-version-3-6
    • I have not yet had the time to perform any further testing. It may be a little difficult for me to test on the same switch since our K2000 runs as a VM in our infrastructure. I can say though that we had a test K2000 that was placed in a VLAN by itself along with a few clients and multicasting was working when they were all in the same VLAN. Unfortunately, that won't work for production.
      • If you are using the same vm file for both your test and production and the servers vm nic settings match I would put it into the networks hands to resolve. One bug we hit once on the vm was someone forgot to disable the servers firewall and that blocked things from working. Hopefully they have support with who ever sold you the core router and switches.

        You could move the test server or change it's nic over to the production side temporarily also since you know that box works. Change the IP of the production to a dummy ip, let test use the production ip while testing and try to do a test multicast from that box.
      • unfortunately I believe the admin has already blown away the test instance. I am thinking too that it is the network configuration, unfortunately, none of the information we have gathered so far has led us to the correct configuration for our environment.
Please log in to comment

Answers

0
One thing that I haven't seen discussed here is the Multicast transmission rate on your K2000 Settings. The key parameter for determining success or failure is the transmit rate. The default is 8 MB/sec, but various circumstances can require dropping the rate lower.
Answered 07/08/2014 by: cblake
Red Belt

  • Are the settings that effect Multicasting documented? It may help them if you can provide a link about the k2000 settings that effect successful multicasting.
Please log in to comment
Answer this question or Comment on this question for clarity