I am having a problem with my MSIs. I believe they are running ok. but they are trying to reinstall something and wanting to access the MSI.

My environment is locked down so I need to build my MSI as an admin to the box.

The process I am using is as follows;

1. I build the MSI on a clean box
2. I then take a clean box and install the msi with admin privilages.
3. Log off and relog on as a user. The MSI wants to run again yet my user will not have access to where the MSI is.

I have set the icons to not be advertised.

What could I be doing that is not right.

Thanks for you help and Happy New Year
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You have to have your MSI in a directory where the users have access. This is how the MSI advertises the application to the user, and applies the correct user profile settings. (advertising shortcuts is only part of it -components, files kept in user profiles, and user reg key settings are also advertised).

I've heard of working around this by having a network share with Everyone:Read pemissions.
Answered 12/29/2004 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
I am not adding any files or icons for user settings. And the shortcuts are set as not advertised

I want all components et all to be installed on the first install.

I have found that I am also having this problem when installing adminstudio 10 on my box. Each time I log onto a box with Adminstudio it wants to reinstall some information. I had originally checked the option to let all users on the computer use the app.

Thanks for you help and input.
Answered 12/29/2004 by: ssweb
Senior Yellow Belt

Please log in to comment
0
Sorry, I meant to say register the per user component settings - the components themselves are already installed.

It's only a problem if it happens every time a user logs on - it's completely normal to install/apply settings from the MSI on first use.

If this is the problem, then use the Wise package validation module or Orca to see any ICE errors.




ORIGINAL: ssweb

I am not adding any files or icons for user settings. And the shortcuts are set as not advertised

I want all components et all to be installed on the first install.

I have found that I am also having this problem when installing adminstudio 10 on my box. Each time I log onto a box with Adminstudio it wants to reinstall some information. I had originally checked the option to let all users on the computer use the app.

Thanks for you help and input.
Answered 12/29/2004 by: aogilmor
Ninth Degree Black Belt

Please log in to comment
0
Is your MSI set to Per-User or Per-Machine installation?

Don't know what you're using to create/edit your MSIs, but in Wise Installer Editor, while in Installation Expert, click on "Administrator Options" in the "Package Options" section and check out what's set for "Install for Profile:". Setting this for "Per-Machine Installation" might very well solve your issue.
Answered 12/29/2004 by: jbonbright
Senior Yellow Belt

Please log in to comment
0
Sorry I did not put the details in the original message.

I am using installshield 10 and do not know how to make an install for only a per machine install.

I have seen info for setting alluser but this does not seem to be setting correclty.

I have found that there is information that is going into the C:\Documents and Settings\Administrator\Application Data and the destination for the component is set to AppDataFolder.

I need it set to alluser\AppDataFolder
Answered 12/29/2004 by: ssweb
Senior Yellow Belt

Please log in to comment
0
An easy way to check out what files that the MSI-package is missing, is to take a look in the Event Viewer (Look in "Application" for warnings with the source "MsiInstaller").

Sounds like that the AppDataFolder is the problem in this case tho.
I think the [CommonAppDataFolder] is the one you are looking for, but not all applications work just changing the directory that way.


/Jonas
Answered 12/29/2004 by: jonasm
Blue Belt

Please log in to comment
0
Try using the ALLUSERS property when you install the msi-package.. it might work...

For example. Do this in "run"--> msiexec /i c:\msi\myprogram.msi ALLUSERS=1

Where you replace the "c:\msi\myprogram.msi" with the path and name for your msi-file.
Answered 12/30/2004 by: Gastro
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity