Hi guys,

I have working on one of the licensed vendor file. I just repacked the exe file into MSI with their services and all necessary files. Its looks fine with /qb install. But i have MSI error 1925 on /qn install and its failed.

Log file says:
Action start 13:46:42: InstallFinalize.
MSI (s) (5C:24) [13:46:42:972]: Executing op: ProductInfo(ProductKey={4D0AB3E0-71AD-4D41-82AD-63177B32FBCA},ProductName=LinguaNextSPeeDDesktop,PackageName=LinguaNextSPeeDDesktop.msi,Language=1033,Version=17104897,Assignment=1,ObsoleteArg=0,ProductIcon=Icon_SPeeDDesktop.exe,,PackageCode={A15265F7-55BA-49BC-9AF5-62AA2A2F3E02},,,InstanceType=0,LUASetting=0,RemoteURTInstalls=0,ProductDeploymentFlags=3)
MSI (s) (5C:24) [13:46:42:972]: Product: LinguaNextSPeeDDesktop -- Error 1925.You do not have sufficient privileges to complete this installation for all users of the machine. Log on as an administrator and then retry this installation.

Error 1925.You do not have sufficient privileges to complete this installation for all users of the machine. Log on as an administrator and then retry this installation.
MSI (s) (5C:24) [13:46:42:988]: User policy value 'DisableRollback' is 0MSI (s) (5C:24) [13:46:42:988]: Machine policy value 'DisableRollback' is 0
Action ended 13:46:42: InstallFinalize. Return value 3.
MSI (s) (5C:24) [13:46:42:988]: Executing op: Header

How to get rid of this. I will much appriciate if any one help me on this..

thanks in advance.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hmmm...tricky one, this. Maybe you could try following the advice in the log entry which says Log on as an administrator and then retry this installation
Answered 04/16/2011 by: VBScab
Red Belt

Please log in to comment
0
There is a launch condition preventing you from performing the install.
Remove "that" condition
Answered 04/16/2011 by: AngelD
Red Belt

Please log in to comment
0
Hi Kim,

Thanks for your reply,

(VersionNT=501 And ServicePackLevel>=2) Or (VersionNT=502 And ServicePackLevel>=2 And MsiNTProductType=1) Or (VersionNT=600 And ServicePackLevel>=1) Or VersionNT>600 - This application requires Windows XP SP2 or Windows Vista SP1 or Windows 7. Setup will now exit.

the above one i have in LaunchCondition. I guess its might not cause the error. But Still i got the same error 1925 after remove the condition too.

One more thing, This MSI Cause this error only on /qn mode of install. Its install fine in /qb mode.

Something i am missing to set about UAC privilege.
Answered 04/16/2011 by: Mani1986
Senior Yellow Belt

Please log in to comment
0
Hi Ian,

Yep Its tricky one. Thats why I came here.,

This Privelege error appears only on /qn install and failed.

Here the one: http://letmeillustrate.blogspot.com/2010/04/error-1925.html

Please take a look at above link. It would make sense that we resolve this in MSI not rather in Admin rights CMD.

I guess its because of UAC privilege popup supress in /qn mode, I used the Summary info word count as bit 3 and ALLUSER PROPERTY as 1. But still got the same error.

Can you able to figure out anything.

Thanks for your help and reply.
Answered 04/16/2011 by: Mani1986
Senior Yellow Belt

Please log in to comment
0
So are you seeing the UAC prompt when running with a basic UI? That kind of information is kind of crucial in diagnosing problems "remotely".

Personally, I see no place for UAC in a properly controlled environment. There should be sufficient controls in place to make UAC redundant.
Answered 04/16/2011 by: VBScab
Red Belt

Please log in to comment
0
Yes., I can see the UAC Prompt in BAsic UI.

Is there a option to make the sufficient controls to shut off the UAC. I didn't get any worth points to make it out.
Answered 04/16/2011 by: Mani1986
Senior Yellow Belt

Please log in to comment
0
Hi Mani,

Okay, so if you install manually with an administrative account but silent you just elevate a DOS console (right-click "Run as administrator") and launch the command line from there.
Answered 04/17/2011 by: AngelD
Red Belt

Please log in to comment
1
Check client polices:
1) AlwaysInstallElevated = 1 and DisableMsi = 0 in HKLM\Software\Policies\Microsoft\Windows\Installer
2) AlwaysInstallElevated = 1 in HKCU\Software\Policies\Microsoft\Windows\Installer
Answered 04/17/2011 by: itolutions
Orange Senior Belt

Please log in to comment
0
Hey Kim,

Yeah.. If I go with Run as administrator in CMd mean its successfully installed. But Is there a way to fix this in MSI itself. Because somewhat tedious process to ask the SCCM guys to do the same for deployment view.

I am facing this kind of prob in my two of the current packages.
Answered 04/17/2011 by: Mani1986
Senior Yellow Belt

Please log in to comment
0
Hi guys,

There is two option is worthy try,. Above said Client policy HKLM, HKCU keys. Turn off the UAC settings in Control pannel. But both the options are affect the other packages in deployment senario.

I yet to get any of the MSI resolutions for this. Please let me know if anyone come across this...

Thanks.
Answered 04/19/2011 by: Mani1986
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: Mani1986

Because somewhat tedious process to ask the SCCM guys to do the same for deployment view.

Wow or ehm ;)

Tell you guys to deploy the package(s) with the system account as it is usually done with any deployment tool including SCCM.
Answered 04/19/2011 by: AngelD
Red Belt

Please log in to comment
0
I just wanted to test drive an install on a VM and ran into the same error. Running it with /qb and then clicking Yes on the UAC warning worked for my scenario.
Answered 06/21/2016 by: KPrinz
Fourth Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity