Hello Guys,

I'm fighting for several days now, to find a way to deploy Microsoft Dynamics CRM 2013 for Outlook unattended with our SCCM.
But the problem is that I need to deploy CRM 2013 for Outlook with offline capabilities. But this doen't work at all... I've tried several ways without succsess.
I've started to install the SQL Server + SQL Server Components on his own, but after that CRM will also install a offline capability if i hit "Go offline!" in Outlook.
SQL Server Compact 4.0 and a language pack but i don't know why.

Did anyone of you successfully deployed CRM 2013 for Outlook with offline capabilities ?

Hope you guys can help me!

Thanks
fehler_404
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
Yes, it deploys but CRM for Outlook would to install SQL Server Compact 4.0 SP1 again and then a Language Pack if you hit "Go offline!" in Outlook.
Answered 06/24/2015 by: fehler_404
Senior White Belt

Please log in to comment
0

>CRM for Outlook would to install SQL Server Compact 4.0 SP1 again
It *sounds* like it's trying to self-heal.

Check the event log for MSIInstaller events with the ID 1001. That will point you to the relevant product (GUID), feature (name) and component (GUID) in the MSI which WI is trying to heal. My bet is that it's either trying to write to a protected file or registry value or, more likely, to the profile of the installing user.

Answered 06/24/2015 by: VBScab
Red Belt

Please log in to comment
0
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="Microsoft-Windows-LoadPerf" Guid="{122EE297-BB47-41AE-B265-1CA8D1886D40}" />
<EventID>1001</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2015-06-19T11:56:03.163257700Z" />
<EventRecordID>5853</EventRecordID>
<Correlation />
<Execution ProcessID="3112" ThreadID="3212" />
<Channel>Application</Channel>
<Computer>VP001548A.domain.local</Computer>
<Security UserID="S-1-5-21-2381373783-202152830-934086887-11482" />
</System>
- <UserData>
- <EventXML xmlns:auto-ns2="http://schemas.microsoft.com/win/2004/08/events" xmlns="LoadPerf">
<param1>crm client</param1>
<param2>crm client</param2>
<binaryDataSize>12</binaryDataSize>
<binaryData>962300009723000034070000</binaryData>
</EventXML>
</UserData>
</Event>




This is the only one that points to CRM. Error Message is:

German:

Die Leistungsindikatoren für den Dienst crm client (crm client) wurden entfernt. Die Daten enthalten die neuen Werte der Registrierungseinträge "Last Counter" und "Last Help".

Translated:

The performance indicators for the service CRM client (CRM client) have been removed. The Data contains the new values of the registry entries "Last Counter" and "Last Help".
Answered 06/24/2015 by: fehler_404
Senior White Belt

Please log in to comment
-1

>this doen't work at all...
Have you got a less descriptive outline of the problem?

Does the deployment fail? Is it that it deploys but not in offline mode? The folks here are pretty clever but somewhat light on psychic powers.

Answered 06/22/2015 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity