I'm hoping someone here has run into this before and can help me out. I'm attempting to deploy Adobe Reader 9.1 to our environment using acroread.msi and Group Policy on a Windows 2003 domain. When users attempt to install from the Control Panel, they are informed that they cannot because Internet Explorer needs to be version 6 or higher. Every workstation in the domain is currently at IE 8.

I'd like to use Orca to remove the IE pre-req/check from the installation since I already know that IE 8 is out there. Except I don't know what keys need to be removed to accomplish this. Any ideas? Please and thank you!

Just Bill
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Start here: http://www.adobe.com/support/downloads/detail.jsp?ftpID=3993 :-)
Answered 01/27/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
I actually started there before resorting to Orca... I guess I missed something in the customization tool?
Answered 01/27/2010 by: JustBill
Senior Yellow Belt

Please log in to comment
0
Hmm are you sure you are starting witht the right version of acroread.msi ?!

Had a quick look at our mst (I didn't create it) and cant see and launchconditions (or anything else for that matter) relating to IE version checking. Sounds wierd that you have IE8 and the MSI is throwing up an error....

BTW, don't you test your deployments in a UAT environment before unleashing them on end users?! Madness [;)]

Regards,
Rob.
Answered 01/27/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Ha! Yes, it is indeed madness... but in the age of lay-offs and no spending, we're hard pressed to get 60% of what needs doing done! Such is the world today I guess.
Answered 01/27/2010 by: JustBill
Senior Yellow Belt

Please log in to comment
0
From what I see in the MSI there's a system search being done for a file shDocVw.dll in the system folder. If it's found a property called MIN_SYSTEM is set.
If that property is not set (i.e that file isn't found) a Custom Action called IsMinIE is triggered, which throws the error.

So, basically, make sure that IsMinIE Custom Action has a condition that's always false, so it never executes.

rgds,

PJ
Answered 01/27/2010 by: pjgeutjens
Red Belt

Please log in to comment
0
Good spot PJ.

Really odd though since we have IE6 in our SP2 and (new - lol) SP3 build and that file exists in both (slightly newer verion in SP3) and the file is windows protected (in the dllcache folder) so why it woudn't be on Bills build is puzzling!

We havent made any amendments to the system search or CA conditions...

We deploy via SMS so maybe it's a GP deployment specific issue?

Cheers,
Rob.
Answered 01/27/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
It seems to be related to user permissions for some reason. Admin level and it works on a machine that will not allow a standard user to install.
Answered 01/27/2010 by: JustBill
Senior Yellow Belt

Please log in to comment
0
I assume you have this setting applied via group policy: http://msdn.microsoft.com/en-us/library/aa367561(VS.85).aspx ?

You can also use this one to stop users installing non managed software: http://msdn.microsoft.com/en-us/library/aa368304(VS.85).aspx

Hope it helps...

Cheers,
Rob.
Answered 01/27/2010 by: MSIPackager
Third Degree Black Belt

Please log in to comment
0
Thanks PJ, it appears to be working now... at least with my one test user. Thanks again!
Answered 01/27/2010 by: JustBill
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity