I have a package with me whose initial version 3.0 is already present in the machine and package is suppose to uninstall 3.0t if that is present and then install 4.0 on the machine through major upgrade.I have hardly any experience in that , pls advise since I need to give prompt delivery !
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers


Please log in to comment
0
Does every package contains the property upgradecode !
If not , how would I match the upgradecodes of 3.0 and 4.0 versions if I dont know if this property is defined for previous version or not ?
Answered 06/06/2008 by: dpu_bansal83
Orange Belt

Please log in to comment
0
ORIGINAL: dpu_bansal83
Does every package contains the property upgradecode !
No, that's not guaranteed.

ORIGINAL: dpu_bansal83
If not , how would I match the upgradecodes of 3.0 and 4.0 versions if I dont know if this property is defined for previous version or not ?
Obviously, you can't. Have you checked if 3.0's MSI *does* contain one? If it doesn't, I guess you could patch it so that it does (cumbersome) or find some other way of uninstalling 3.0, such as building an EXE stub to execute 3.0's uninstall string and then install 4.0.
Answered 06/06/2008 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity