Created KBOX Boot Environment with Win PE x64. Problem here-- it cannot find KBOX 2000 server. Both computer name and actual IP address were used, but no luck. I'm able to boot into that CD with network, (can map to shared drives via network). I am unable to figure out what the last message really means. The message reads: (after the command, "wpeutil DisableFirewall")

The command completed successfully.

*** Waiting for network devices to settle

*** Checking if this is a UFD boot and an image is prepped for deployment

*** Locating KBOX IP address from DHCP option 66 or 244

x:\windows\system32>kgetdhcp 66 1>x:\windows\TEMP\kbox-ip-address

x:\windows\system32>if errorlevel 1 kgetdchp 244 1>x:\windows\TEMP\kbox-ip-address
"ERROR: Unable to determine KBOX IP address"


By the way... I went into the TEMP directory and opened kbox-ip-address file. It reads: no data


Thoughts or advices?

--jeff
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
This applies to K2000 version 3.2 using the new PXE boot environment using WinPE3 now called KACE Boot Environment (KBE)

confirm if your NIC has an IP address by running ipconfig from within your KBE (WinPE3) environment
if you get nothing in return, then the NIC drivers have not been loaded

map a drive to \\[your k2000]\drivers and copy network and storage drivers into the \kbox_winpe3_x86 and/or \kbox_winpe3_x64 directory, then rebuilt/recreate your KBE (WinPE3) by creating KBOX Boot Environment using the KBOX 2000 Media Manager

Note:
every time you update drivers either by using the Driver Harvesting Utility or by manually mapping a drive to the \drivers share and manually copying over drivers, you will need to also copy network and storage drivers to the \kbox_winpe3_x86 or _x64 directories to support the PXE boot into KBE and then re-create the KBOX Boot Environment using the KBOX 2000 Media Manger

Don't forget to go back to General Settings and change the "Default KBOX Deployment and Recovery Environments:" to reflect your new boot environment.

KBE = KACE Boot Environment - the new PXE Boot environment using WinPE3; this is a new PXE environment which boots a lot faster than KPE
KPE = KACE Pre-boot Environment - the old PXE Boot environment using WinPE2005

FYI:
Creating the KACE Boot Environment (KBE - WinPE3) is not supported on WinXP.

KBE is created by the Windows Automated Installation KIT (AIK) for Windows 7
Here are the Supported OS for AIK: (referenced: http://go.microsoft.com/fwlink/?LinkId=136976 )

Supported Operating Systems: Windows 7; Windows Server 2008
  • Windows Server 2003 with Service Pack 2
  • Windows Vista SP1
  • Windows Server 2008 family
  • Windows 7 family
  • Windows Server 2008 R2 family
Answered 04/02/2010 by: tstaub
Second Degree Blue Belt

Please log in to comment
0
Was this issue ever resolved? I'm having the same or a very similar problem. The network drivers are loading fine because I can ping my KACE server (and other addresses/names) and map network drives. I talked to a Dell KACE support engineer who said that if I create a bootable KBE USB drive, the changes don't need to be made to the routers/DHCP servers. I'm wondering if my hostname is causing a problem. I called the K2000 box "K2000-TEST". I'll attach a file with the messages I see when trying to connect to the K2000.

Attachment

Answered 03/14/2011 by: Colorado
Senior Yellow Belt

Please log in to comment
1
ORIGINAL: Colorado

Was this issue ever resolved? I'm having the same or a very similar problem. The network drivers are loading fine because I can ping my KACE server (and other addresses/names) and map network drives. I talked to a Dell KACE support engineer who said that if I create a bootable KBE USB drive, the changes don't need to be made to the routers/DHCP servers. I'm wondering if my hostname is causing a problem. I called the K2000 box "K2000-TEST". I'll attach a file with the messages I see when trying to connect to the K2000.


Hi Guys I found a way around it by using the below commands when the script stops running:

net use Y: \\(VK2000 IP)\peinst - Hostname is fine as well.
net use T: \\(VK2000 IP)\petemp
Y:\hta\x86\UltraVNC\winvnc.exe - For VNC access to the client.
set KBOX_IP=(VK2000 IP) - Doesn't need bracket's.
Y:\hta\deploy.hta

eg.
net use Y: \\10.20.1.111\peinst
net use T: \\10.20.1.111\petemp
Y:\hta\x86\UltraVNC\winvnc.exe
set KBOX_IP=10.20.1.111
Y:\hta\deploy.hta

I did this because I have an Altiris PXE service in place and I couldn't change options on the DHCP scope without losing the Altiris functionality.
Answered 07/26/2011 by: gumbi_18
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity