I upgraded to 6.0 yesterday and everything went well for the most part. Most user agents were upgraded to 6.0 when they checked in, but I have 10 that will not upgrade. I tried to push the new agent out to them, and while KACE successfully connects to the machine, the installer file is reported as not found. Reinstalling the agent onto the KACE also didn't fix the issue, nor did enabling/disabling the file share. I also noticed that the file share cannot be browsed from \\hostname\client, it simply returns a not found dialog. Trying to download the file from the URL below returns a file not found error within the KACE. Anyone know what is going one here?

   STEP 2: AUTHENTICATION - SUCCESSFUL

      Opening pipe to service
      Sending commands
      Sending login credentials
      process (//kbox/client/agent_provisioning/windows_platform/agent_msi_provision.bat kbox client ampagent-6.0.1079-x86.msi kbox) could not be launched: 2 The system cannot find the file specified.
       (authenticated, but CreateProcessAsUser failed)process (//kbox/client/agent_provisioning/windows_platform/agent_msi_provision.bat kbox client ampagent-6.0.1079-x86.msi kbox) could not be launched as LocalSystem: 2 The system cannot find the file specified.
      Removing service (Exit code: 0)

6 Comments   [ + ] Show Comments

Comments

  • What are the agent versions on the 10 machines?
    Have you tried to remote into a machine and manually install the agent?
  • I too am having this problem. If I try to reach my kbox using the FQDN, it fails. If I use just the name, I can map to it. IP address works fine too. But I am receiving the same error message as above.
  • I am having similar issue after upgrading Kace to 6.0. Seems to only occur on Windows 7, 8, and 8.1 64-bits. It will upgrade existing agents, but when attempting to provision it failed. Looks like it kept on stating MSI Installer is the culprit, but that cannot be correct because agent 5.5 was able to push from the appliance perfectly fine.

    STEP 2: AUTHENTICATION - SUCCESSFUL

    Opening pipe to service
    Sending commands
    Sending login credentials
    Begin agent_msi_provision.bat processing.
    Detected 64-bit platform.
    Executing MSI installer.

    C:\windows\TEMP>start /wait msiexec.exe /qn /l*v C:\windows\TEMP\ampmsi.log /i \\kace\client\agent_provisioning\windows_platform\ampagent-6.0.1079-x86.msi HOST=kace

    C:\windows\TEMP>echo off
    MSI Info: [ERROR_INSTALL_FAILURE] A fatal error occurred during installation.
    Access is denied.
    K1000 Agent is not installed.
    AMP is not connected.
    ERROR: The system was unable to find the specified registry key or value.
    KUID value not written by MSI installer.
    End agent_msi_provision.bat processing.
    Removing service (Exit code: 0)
    Connecting to ADMIN$
    Deleting service file
    Disconnecting ADMIN$

    STEP 3: PUSH SCRIPT\PROVISIONING - FAILED
    • I was able to get it to deploy by doing the following:

      1) Change UAC GUI to lowest option

      2) HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

      In the details pane (Right Pane), locate the EnableLUA key (REG_DWORD type). Double click to Modify. In the Value data box, type 0 (zero), and then click OK.

      We are able to deploy now. Works on 2008 and 2012/2012 R2
    • If already installed on a client I have had to uninstall the original agent by following the KACE uninstall instructions:

      Solution:
      On the client system that has the KACE agent, please follow the steps below to uninstall the KACE agent:
      Type cmd in the search programs and files box.
      The cmd box will pop up. Go to c:\Program Files (or Program File x86 if 64 bit)\Dell\KACE
      Type amptools.exe uninstall. The AMPAgent will stop and the agent is uninstalled
  • We just upgraded our KACE 1000 to vs 6. We can no longer deploy the Agent either: Any feedback?
    • I was able to get it to deploy by doing the following:

      1) Change UAC GUI to lowest option

      2) HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

      In the details pane (Right Pane), locate the EnableLUA key (REG_DWORD type). Double click to Modify. In the Value data box, type 0 (zero), and then click OK.

      We are able to deploy now. Works on 2008 and 2012/2012 R2
      • Solution:
        On the client system that has the KACE agent, please follow the steps below to uninstall the KACE agent:
        Type cmd in the search programs and files box.
        The cmd box will pop up. Go to c:\Program Files (or Program File x86 if 64 bit)\Dell\KACE
        Type amptools.exe uninstall. The AMPAgent will stop and the agent is uninstalled
  • Upgrading the current agent from 5.5 to 6.0 were no issue. It was installing the new 6.0 agent. After disabling UAC on the client system it seems to work.

    I worked with a Kace Rep and they stated nothing was changed from 5.5 to 6.0 on the installation of the agent. From their understanding it still require UAC to be disabled for both 5.5 and 6.0 to be push from Kace appliance. Which still make no sense to me why it worked previously, but not with the new 6.0 agent. Our GPO for UAC is only disabled for users that have local admin access. That has been working for nearly a year with McAfee Agent and Kace Agent.
  • Apologies for resurrecting an old thread, but we're experiencing the exact same problem. I can get to the share through IP, but not hostname or FQDN. Has there been any definite fixes or updates on this problem? Thanks.
Please log in to comment

Answers

1

We are also having the same problem.  I've noted that in the Network Settings on the K1000 the DNS entries for DNS2 show the same entry as DNS1, and no matter how we try to change DNS2 to point to a different IP, after changing it the K1000 reboots and shows the same IP as DNS1.  However, as many have noted, this doesn't appear to be a DNS issue.

We opened a Ticket with KACE.  They told us a couple of things: They said that the client share isn't accessible (on Windows machines) via the HostName of the K1000, but only via the IP address on version 6.  Also, they said that the if Windows UAC is enabled and turned on (regardless of where you have it set), that this could be a factor that would possibly block the agent provisioning/installation.  We turned off UAC, but that didn't help.

I'm curious to know if anyone else has tried Timi's installation method above of creating a script to install the agent, and if that has worked for anyone.  Timi: did it, in fact, work for you?  I tried to manually run the agent installation batch file from a command prompt, and it didn't work.  I was going to attempt a script next as you had done.

Answered 06/03/2014 by: vitoasaro
White Belt

Please log in to comment
1

Can you check if you can resolve the k1 name from that client machine ?

Answered 05/15/2014 by: AbhayR
Fourth Degree Black Belt

Please log in to comment
1
The kace appliance name resolves to its IP address successfully from any client machine
Answered 05/15/2014 by: bharrison
Yellow Belt

Please log in to comment
1

I created a script to address this issue in my environment.  I copied the amp.conf file (located in c:\programdata\dell\kace) from a system that has the server name in it.  You can provision the agent using the ip address of the server instead of the host name and that will get the agent out.  I then created a script that had the amp.conf  as a dependency.  I've attached a screenshot of the steps that I did to create the script. Basically I am replacing the amp.conf file on the systems that had the ip address for the server in amp.conf with one that has the server name. 

Answered 05/15/2014 by: Timi
Seventh Degree Black Belt

  • Timi- I noticed that you had a simimular fix as we are proposing. The only problem is that we have 600 machines that are not showing up due to the amp.conf file being wrong. I posted a question in a new thread. Can you please assist?
    http://www.itninja.com/question/rollout-of-k1000-did-not-work-properly-need-to-edit-amp-config
Please log in to comment
1
I have the same issue. I can uninstall or install the agent on an XP workstation since it will browse the samba share using the kbox name just fine. The issue is with the Windows 7 workstations I found. Still waiting on support to get back to me also.
Answered 05/16/2014 by: dmccallie@cityofowasso.com
White Belt

Please log in to comment
1

I was able to get it to deploy by doing the following:

1) Change UAC GUI to lowest option

2) Change Reg Setting for UAC:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

In the details pane (Right Pane), locate the EnableLUA key (REG_DWORD type). Double click to Modify. In the Value data box, type 0 (zero), and then click OK.

We are able to deploy now. Works on 2008 and 2012/2012 R2


NOTE:  Solution:

On the client system that has the KACE agent, please follow the steps below to uninstall the KACE agent:
Type cmd in the search programs and files box.
The cmd box will pop up.  Go to c:\Program Files (or Program File x86 if 64 bit)\Dell\KACE
Type amptools.exe uninstall. The AMPAgent will stop and the agent is uninstalled
Answered 06/17/2014 by: RhiannonDeThomas
White Belt

Please log in to comment
1

Same problem here. Contacted Kace support and they shuttled me off to Tier 2 support and said I should be getting a call back within 48 hours.

Are you able to browse the file share on the KBOX using the hostname? I found that I am no longer able to, though I believe that I could previously on 5.5, and I think that may be the cause of the issue...

I did discover that I can access it by using the IP address rather than the hostname. When I found that, I immediately thought it may be a DNS issue, but I checked and everything still appears to be correct on our DNS server, and we are able to access the web interface and ping the K1000 using the hostname just fine, but the share is just inaccessible.

If they find a solution for you, please be sure to share. I will do the same when our issue is resolved.

Answered 05/14/2014 by: Michael4732
Orange Senior Belt

Please log in to comment
1
I too am able to browse the fileshare by IP address, but not hostname. Good call, I hadn't thought to try that! Agents pushing still doesn't work though, but at least I know the file share is working properly
Answered 05/14/2014 by: bharrison
Yellow Belt

Please log in to comment
1

Try resaving the "samba share settings" from the Settings->Control Panel->general settings page and then access it.

Answered 05/14/2014 by: AbhayR
Fourth Degree Black Belt

Please log in to comment
1

After resaving and reboot - i no longer can acces it at all using the domain name. Using IP still works fine tho.

Answered 05/15/2014 by: mikt
White Belt

Please log in to comment
0
After upgrading to Version 6.0, we too are experiencing this issue. DNS settings all appear fine, able to ping using host name and IP address, however not able to access \hostname\client using host name or IP Address. Samba share is turned on as well.
Answered 05/15/2014 by: jgamble@hcsbank.com
White Belt

Please log in to comment
0

Try "K1000." or what ever you used as name (!!! with a trailing dot).

Do not change your DNS record, that one should be already correct.

Go to K1000 appliance after distributing the client software failed and open Settings\Provisioning\schedules and click on a the record with a client that failed. Change the content of "K1000 Server Name or IP Address" into the IP address or "K1000."

Choose action "Run Now" to distribute the client again and now the installation of the client should succeed.

Must be an issue on the K1000 appliance when trying to access a share using the DNS name.

 

Answered 11/14/2014 by: Jaep
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity