I've got a problem with lots of clients having updates forced by Kace and then automatically rebooted without any warning. It happens every month, first week day. I thought that it must have been scheduled.
I thought about the Agent Updates and Patch Settings. I've made sure that the Agent Updates are not Enabled.
What I haven't checked yet is Advanced Provisioning and Provisioned Configurations.

This is a problem for many reasons and I have checked the settings on the server.
Still, shouldn't the user have the option to postpone the update, or maybe have the opportunity to reboot the computer later?

Any suggestions on what is causing these updates to be pushed?
Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
Hi,

You isolated this has happening at a certain time which could indicate a schedule. Agent updates should not cause reboots.

I would check the following areas for schedules running.

Patching's Detect and Deploy Patches - Look for any Detect and Deploy schedules that are turned on
Scripting - check any scripts you have enabled and their schedule. Scripting itself wouldn't reboot a system but commands in the script might.
Software Distribution - checking to see if any software installs are using a force reboot after installation via a run parameter or full command line.
Answered 01/03/2012 by: nshah
Red Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It's possible that I've found it... or I should say that I've most likely found the problem.
I found a Scheduled task under Distribution/Dell Updates and then Inventory and Update.
The settings for this task were:
- Run on All Supported Dell Systems (checked)
- Microsoft Windows 7 SP1... was selected on OS list.
- Deploy All Applicable Packages (checked)
...- Apply Upgrades Only

- Alerts was not enabled, which has the option to allow the user to Snooze or even Cancel.
- Reboot Options was set to Prompt User, with a specified message.
...- Timeout Action: Reboot Now.

- Scheduled to run on 1st every month at 01:00.
...- Run on next connection if offline (checked)

All these settings seems to match everything that has been reported by the users. They didn't get any option to Snooze and it rebooted immediately. The message was the same as the users received. etc..
The strangest thing, I do not recognise this task at all and I'm certain that I haven't created it. I guess I'll need a talk with some of my colleagues. ;)

Thanks for pointing me to the right direction! I was staring my self blind at the Agent Updates.. It will probably take a month until I can confirm that this change solved my little mystery, but what else could it be..
Answered 01/03/2012 by: Sinbad
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity