Looking to push Java out via Kace. I have a VM running OS X 10.9 and have installed JDK 8 update 25. After install I did a force update and Kace does not see Java installed on my machine. Why don't Kace see Java installed? I can run the command java -version and see thats its installed, but still don't see it in Kace. 
Answer Summary:
0 Comments   [ + ] Show Comments


Please log in to comment



Do the same for me on Windows 8.1 64bit. Got a k1000 which work fine with every other soft except Java 8u25 (64 or 32) and Flash Player Active X.
I do not see these soft installed on the computer.

But i found something in order to see the soft on Kace: in your "personalized rule" of Java, add the regedit path of Java like this

Then you are able to see Java in Kace:

Hope this can help a bit.

Answered 01/21/2015 by: Olendis
Senior Yellow Belt

Please log in to comment
Since Java isn't an application KACE does not detect it. I created a custom inventory rule to capture Java versions on our computers:
ShellCommandTextReturn(java -version)

Of course if you want to deploy Java then you need a custom inventory rule that will find the specific version that you are deploying. You can do this by looking at the Java plugin. Here's a rule that finds a specific version:
PlistValueEquals(/Library/Internet Plug-ins/JavaAppletPlugin.plugin/Contents/Enabled.plist,CFBundleVersion,TEXT,

I don't know if that rule still works for the latest version but it is worth checking.
Answered 01/21/2015 by: chucksteel
Red Belt

  • Chucksteel
    Kace does detect Java in all Windows boxes. Does Kace look in particular directories on Mac for installed software?
    • That's because on windows there is a javaw.exe that KACE detects. It also appears in the Windows Add/Remove Programs list which KACE also utilizes. I believe on MacOS it performs a search for folders named .app and catalogs those.
  • It's similar to this: http://www.itninja.com/blog/view/java-os-x-and-your-k1000
Please log in to comment
Answer this question or Comment on this question for clarity