We've been PXE booting machines via K2000 for image deployment for months with no problem.  This past Friday, however, PXE booting abruptly stopped working.  When attempting to PXE boot an Optiplex, we get the following series of messages:

PXE-T00:  Permission denied
PXE-E36: Error received from TFTP server
PXE-M0F: Exiting Broadcom PXE ROM.

If I try to netboot a Mac, it simply boots from the hard drive without presenting any error message.  I have tried multiple machines, both Dell and Mac, so it is not an issue with a particular computer.  So far as I can determine, nothing relevant has been changed either in our campus network settings or in the K2000 configuration, though I could be missing something.  I am still able to access the K2000 web interface.  Restarting the K2000 server did not resolve the issue.  Anyone have any suggestions on this?

Answer Summary:
They tethered in and found a permissions error which was responsible.
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


The errors show you are reaching the k2000 so dhcp should not be the problem.

First check your dhcp option settings for the scope you are booting in and make sure option 66 and 67 are correct and something did not change those.  It is not allowing you acces to tftp files on the server.  I would call support on this sounds more like the files are missing. corrupt, the file name is wrong or rights changed somehow.


Answered 05/16/2013 by: SMal.tmcc
Red Belt

  • netboot uses a different set of files vs pxe
  • Calling Support would be a good idea here. It looks as if something in freebsd blocksize settings might be fragmenting the UDP packets. Just for kicks it might be worth getting with your network admins and having them double check that the switching is allowing TFTP traffic and that you have no conflicting TFTP servers on the same subnet(s).
  • This ended up being what we had to do. They tethered in and found a permissions error which was responsible.
Please log in to comment



Are you using the built in DHCP and ran out of addresses in your scope?  If so, try deleting and recreating the scope.

Answered 05/16/2013 by: philologist
Red Belt

  • On-board DHCP is not enabled.
Please log in to comment
Answer this question or Comment on this question for clarity