Hi, we have an issue with our deployment. We boot to PXE select the KBE and then the iso is loaded.

The script runs to get the IP (kgetdhcp) it gets the IP but its completely different to what our kace 2000 is.

for example our k2000 is but the IP it picks up is (example only but they are different ranges)

on our DHCP server '66' is set to the correct IP if i run the kgetdhcp.exe on my PC or any PC that has already been built it picks up the correct IP

to be even more confusing, if i run kgetdhcp about 15-20 times on the PC im building it will get the correct IP after a while.


any ideas?

Answer Summary:
2 Comments   [ + ] Show Comments


  • Almost sounds like you have two different DHCP services broadcasting.
  • we only have one DHCP box but it has a few different scopes 132.1.x.x is our legacy range and 10.64.x.x is our new range. but all scope options are set correctly in 66 and 67
Please log in to comment



Sounds like you moved the kbox or changed DHCP after the bootenv's were created.  Use media manager and upload new KBE's and see if that stops it.

Answered 07/03/2013 by: SMal.tmcc
Red Belt

  • boot to the KBE from the main menu choose recovery and open a command window
    type "notepad startnet.cmd" and look at the file for the hard coded ip the box goes to if kgetdhcp fails

    @echo *** Locating KBOX IP address from DHCP option 66 or 244
    kgetdhcp 66 > %TMP%\kbox-ip-address
    if errorlevel 1 kgetdhcp 244 > %TMP%\kbox-ip-address
    @if errorlevel 1 (
    @echo ERROR: Unable to determine server IP address from DHCP
    @echo WARNING: Using hardcoded K2000 IP address as fallback
    @echo> %TMP%\kbox-ip-address

    Note the IP above that will be used if the dhcp does not have an answer.
  • thanks, this is were it gets really strange. 66 on our scope option is (our remote appliance), we dont have 244 set. the hard coded IP is our main kbox which is

    however it doesnt fail to get the DHCP IP it just gets the wrong IP address which is if i open up kbox-ip-address file it shows
    because it gets the 132 address it doesnt use the hard coded kbox addess.

    now if i run kgetdhcp.exe on a machine that has already been imaged it brings back the correct IP
  • Sounds like something is still configured to the old server. One workaround would be to use KBE Manipulator [http://www.kace.com/support/resources/kb/article/k2000-useful-scripts] to configure a static IP address for your KBE (of course different ones would need to be made for RSAs).

    Lead L3 Enterprise Solutions Engineer, K2000
    If my response was helpful, please rate it!
  • thanks to everyone who helped. we used the manipulator as a temporary way to do scripted installs but since then i found out that someone had turned on an old backup dhcp server. even though in that server the scope options were correct turning the server off made our image work again.....
Please log in to comment
Answer this question or Comment on this question for clarity