Now that we have 3.6  we have these extra logins. I read all the stuff I could find and changed up my sysprep  autologin to 5  that did not change anything. I checked the box on my one postinstall (kace agent) still the same... pulling out my hair

How in the world do I get rid of the manual logins and just turn them into auto logins.

My Task List

Preinstallation Task
Collect Computer Name
Create Single Partition
Format C: as NTFS
Install Vista/2008/7/8/2012 MBR
Apply Image
Set Kace Path
Apply Computer Name
Fix BCD
Copy Drives
Copy Post Install Files
Setup Post Install Tasks
Update Configuration For OS Tasks
Set Engine Run Key
Disable UAC
Run DPInst
Kbox 1000 Agent Software 5.5
Enable UAC
Cleanup

4 Comments   [ + ] Show Comments

Comments

  • <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <WillReboot>Never</WillReboot>
    <Path>net user dministrator /active:Yes</Path>
    <Order>1</Order>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
  • <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <AutoLogon>
    <Password>
    <Value>######################</Value>
    <PlainText>false</PlainText>
    </Password>
    <Enabled>false</Enabled>
    <LogonCount>5</LogonCount>
    <Username>Administrator</Username>
    </AutoLogon>
  • I also use the user account since it is disabled by default.
    I script a image then build on that image all the software and settings and clean it up. Then I syprep the image pull it into the k2000 immediately. Command I use cd c:\windows\system32\sysprep
    syprep /generalize /oobe /shutdown /unattend:e:myfile.xml

    We have imaged over 8000 machines and had no issues with imaging (had a lot of issues figuring out how to at begining) but now with the 3.6 I have these extra logins before you have a completed image.

    I just now came across this which will help on one login:
    "Disable the DPInst Reboot in K2000 3.6
    Posted by cserrins 04/30/2014 - More from cserrins Many tasks have changed in 3.6 and moved from one .bat file into seperate tasks.

    When an image has the driver feed box checked, the dpinst command is automatically added to the deployment to account for Windows XP images. The task won't do anything in Windows 7 and higher because no drivers were copied into the KACE directory for dpinst to use, except for the fact that it has a "Reboot" assigned to it and this has affected many unattend.xml autologon count issues. If you aren't deploying XP, this task isn't really needed, but since it doesn't hurt anything, all we really need is to remove the reboot.

    Download the remove_dpinst_reboot.zip file and decompress the file.

    Browse to Settings and Maintenance | Package Management | Import K2000 Packages. From the choose action drop down menu select "Upload Package for Import" and select the .pkg file from the decompressed download.

    This is a mid-level Windows Script Task."
  • Were you ever able to solve this issue? I am still having the manual login problem.
Please log in to comment

Community Chosen Answer

1

I saw you mentioned you have 5 autologins in your sysprep file.

I use a user other then adminstrator in my answer file since it is disabled by default

if are using administrator make sure you have this in your answer files

 <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <RunSynchronous>
                <RunSynchronousCommand wcm:action="add">
                    <Path>net user administrator /active:yes</Path>
                    <Order>1</Order>
                </RunSynchronousCommand>
            </RunSynchronous>
        </component>

Where in the task list is this happening?

I have also ran into a wierd thing that if it the box was already auto logging in when I  syspreped, the answer file autologon task did not run correctly.  I have a batch file that runs my sysprep and I added a line to set the adminautologon key to 0 and it solved my problem.

Answered 05/09/2014 by: SMal.tmcc
Red Belt

  • Are you saying that if you use the User account "Do not add this in? Or does it not matter.
    <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <RunSynchronous>
    <RunSynchronousCommand wcm:action="add">
    <Path>net user administrator /active:yes</Path>
    <Order>1</Order>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
    I only use the User account because the admin account is disabled.
    • I would always add it if you want "administrator" to be active in the end if you use a different account it does not matter
      • you want to have the machine redo autologin as a post task. do you even have any post tasks?
      • The only post task I use right now is the agent. For the admin account it is disabled until we put it on domain then the GPO disables the user account adds a new accout and changes the admin account name and password but this all happens after computer is imaged and we manually check computer name and add it to the domain.
Please log in to comment

Answers

0

Hello,

 

you can try to amend your sysprepp and add to it this component:

 

<AutoLogon>

        <Enabled>true</Enabled>

        <Username>admin</Username>

        <Password>

          <PlainText>true</PlainText>

          <Value>pw</Value>

        </Password>

        <LogonCount>4</LogonCount>

      </AutoLogon>

      <ComputerName>*</ComputerName>

    </component> 
 
Kind regards,
StockTrader - Marco 
Answered 05/09/2014 by: StockTrader
Red Belt

  • Thanks I tried that still the same but I came arcoss this and it helped remove one login:
    Disable the DPInst Reboot in K2000 3.6
    Posted by cserrins 04/30/2014
Please log in to comment
Answer this question or Comment on this question for clarity