I'm currently testing our next monthly rollout of critical patches and I'm having an issue getting the patches to deploy in a timely manner.

This is a custom schedule, so all the scheduling options are turned off.  In the past, when I've clicked 'Save and Run Now' the status for the individual boxes will go to scheduled and then within 15 minutes or so the patches will start deploying.

Now, however, when I click 'Save and Run Now' the boxes will sit in 'scheduled' status for hours before finally deploying.  For example, yesterday I kicked it off at 1pm and nothing had happened by the time I left at 5pm.  When I got in the next morning, all the test boxes had patched and rebooted around 8-8:30pm.

What can I do to resolve this?


4 Comments   [ + ] Show Comments

Comments

  • I'm having the exact same issue. We often run on a "managed
    schedule where we manually kick off groups of servers to patch based on variable criteria... I'm pre-patching a few servers on the new 6.4 KBox, and they're just sitting there as "scheduled". They won't start patching. I need to be able to manually trigger patches to go when I need them to go! "Run Now" is pretty suggestive as to when it's going to run. Why not?
  • In testing further -- I've created multiple new jobs for patching, I've had them set to "none" for schedule, and I've had them set for 5 minutes when I saved, and they still don't kick off. Not being able to Run Now is a problem. Not being able to Run at a pre-scheduled time is a HUGE problem. I have a ticket opened for this now.
  • In testing further, further... it looks like my scheduled overnight jobs for patch detects (run every morning at 3:30am) are running between 6 and 7am against the couple of servers they're set to run against... This had escaped my detection after we did the update to 6.4 this past weekened.
  • Having the same problem at one of our Remote Sites do you know what your connection per hour is now? We are also on 6.4.
Please log in to comment

Answers

0
Called KACE Support last night. They remoted in and we flipped through many pages and did multiple connection setting changes (apparently we had too many connections per hour for 6.4). We then cleared the entire agent task queue because it was very backed up. When complete, we rescheduled the patches and did "Run Now". They ran instantly.

I said "too many connections per hour for 6.4" specifically drawing the attention to the version, because I think there's an underlying issue. Maybe it's with FreeBSD 10 limiting incoming connections to 200, where the previous version was less strict, maybe it's something else... But our 6.3 device could handle 4000 machines with 4 or 6 hour inventories since the day it came out. 6.4 needs a setting of 2 days to keep the connections per hour to a manageable level? I don't know...

Call Support if you don't know how to clear the Agent Task Queue, and that will get patching working. 
Answered 11/19/2015 by: NinjaMellen
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity