Hello,

I'm running 6.4 of the K1000.

I'd like to force my users to select a due date whenever they make a ticket.  There is an option to make the due date field required, but it defaults to none.  If you mark the field as required, and if the user creates the ticket and just leaves the value as none, KACE accepts the ticket with none as the value.

I want to make it to where my users cannot select none.  I want them to be forced to select a due date before the ticket can be submitted.  How can I accomplish this?  How will this work for tickets submitted via email?
2 Comments   [ + ] Show Comments

Comments

  • Hello,

    I'm not able to reproduce this behavior using a 6.4 and Chrome.
    What browser are you using?
    Kind regards,
    Marco - StockTrader
  • It only happens when you make a new ticket. If a ticket is already created and you try to change the due date to none, it won't allow it. If you make a new ticket and leave the due date as none, it allows it.
    • Sounds like a bug...I mean feature.
    • Hi..I'm still not able to reproduced it on my server.
      Maybe I'm missing something.
      I shot a video: https://youtu.be/3sZijuoQ4hY
      Regards,
      Marco - StockTrader
      • In your video you set the custom date field you made to user modify instead of user create. I just tried this hoping that was the issue but it didn't resolve anything for me.

        I also noticed you make a custom field in your video and label the type as date. I'm not doing that. I'm using the built in field called due_date. I'm not making a custom field. This may be why you can't recreate the issue.
  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment

Answers

-1
I think that is Working as Designed.
You are using the DUE_DATE field and you set it as User Create / Always Required.
So for that particular field NONE is a valid attribute that assign to it the value NONE and so using the logic that a ''value'' is required for that field it is accepted.
There is no way to force in the form the user to select something different from None using that field.
Kind regards,
Marco - StockTrader
Answered 11/11/2015 by: StockTrader
Red Belt

  • As seen in your test when making a custom field and labeling it as date, KACE will not allow none when it is done that way.

    I think the due_date field should behave the same way as a custom date field, which means none should not be accepted as a value.

    Also if you create a ticket with the due date as none, then change to to a date, save it, and attempt to change it back to none, KACE will not accept it. Because of this behavior It would stand to reason this is a bug, and KACE did not intend to allow none to be selected on ticket creation.
    • That field is a bit particular: a normal date field does not have the ''NONE'' option.
      "Working as Designed" means literally that and does not always imply that is ''designed as the human logic would like it to work''.
      I agree with you that the behaviour is somewhat ''particular''.
      If you like to can open a ticket and/or file an ''idea'' on http://kace.uservoice.com/
      Kind regards,
      Marco - StockTrader
      • I don't see how this could be considered working as designed. If it was working as designed, KACE would allow a user to create a ticket with none, change the field to a date, save it, then change it back to none and save it. As it is, once a date is selected, KACE will not allow it to be set back to none. This suggests it is a bug, and KACE did not intend for none to be an option on ticket creation.
      • Hello,
        Just to piggyback on edwimbs’s observation here, I’ve noticed this as well on our K1000 6.4 version. When a user tries to create a new ticket, they are able to save the ticket when they select “None” (more than likely just forgets to pick one) on the built-in Due Date field even though we have set as a required field. I was thinking sure, “None” is a valid option so no problem right?
        The issue comes up when you try to close the ticket. From what I have observed, KACE won’t allow you to close the ticket until you’ve selected a specific date on the Due Date field because as it states “the Due Date is required”. So we are having to pick some arbitrary date so we can close the ticket. So really, I’m not sure if this is by design, or if it’s a bug that needs to be fixed.
Please log in to comment
Answer this question or Comment on this question for clarity