Dear all,

I have been spending a lot of time trying to find how to better install JRE 8u51 but no successfull so far...

I'm preparing a new MDT image and basically I need to install JRE 8u51 silent and to the maximum level possible ensuring that JRE will no be auto-updated and also that no any kind of new version available message will appear to the user.

After the search I think that the best option is to use the .msi and the parameters:

JU=0 JAVAUPDATE=0 AUTOUPDATECHECK=0

unfortunatelly Java doesn't provide the .msi and what's more, Java says you should not obtain it from the .exe because it will not work fine (at least this web ensures that:http://www.klaus-hartnegg.de/gpo/msi_java8.html).

If I use the command line installation jre-8u51-windows-i586.exe AUTO_UPDATE=0   

is this equivalent to the .msi parameters JU=0 JAVAUPDATE=0 AUTOUPDATECHECK=0  ?

I just want the users not to be bothered by Java update messages.

I know this is not the Java forum but Oracle forums are not easy to understand.

Thank you very much for your support!

Javi

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1
The .exe should use similar parameters to the .msi. I would try using the default installation option in Distribution with the following parameters:  /s /v /norestart AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0. I've used this command line on previous versions of Java without any issues, so it should work for JRE 8u51. 
Answered 08/14/2015 by: tekfiend
Blue Belt

Please log in to comment
1

Change Java Registry Keys

Open RegEdit on the Windows 7 or up PC. Before making any registry changes, it is recommended to first create a backup.

To disable the Java Update Notifications browse to the following registry keys

32bit Users:

HKLM\SOFTWARE\JavaSoft\Java Update\Policy

  • Change the EnableAutoUpdateCheck to 0
  • Change the EnableJavaUpdate to 0

64bit Users:

HKLM\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy

  • Change the EnableJavaUpdate to 0
  • Change the NotifyDownload to 0
  • Add a new DWORD called "EnableAutoUpdateCheck" and set to 0
Answered 08/14/2015 by: WhitzEnd
Seventh Degree Black Belt

Please log in to comment
1
To suppress out-of-date, put the following line in Deployment.properties
deployment.expiration.check.enabled=false
deployment.expiration.check.enabled.locked
Set an environment variable
setx deployment.expiration.check.enabled false /m
Answered 08/20/2015 by: jagadeish
Red Belt

Please log in to comment
0
The auto-update stuff unfortunately doesn't prevent JRE from nagging you that it's out-of-date.

http://www.itninja.com/question/disable-jre-17-u40-update-prompt
Answered 08/17/2015 by: VBScab
Red Belt

Please log in to comment
0
I disabled the EnableJavaUpdate registry key mentioned above and deploy the exe with the /s switch. Another problem is web browsers will block and warn about outdated Java. I gave up trying to find all the settings.
Answered 08/17/2015 by: jegolf
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity