Hello 

When I install the new JRE 7 update 21 in Windows 7 from the extracted MSI file I get an error when I try to start the Java control panel. 

If I uninstall java and install it from the offline exe file the control panel works. 

 

I have used the same MST file properties that i have used with previus versions. I have also tried to install it without any MST file or MSI property values but I get the same error.

 

Regards 

Markus

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2

I got the same Error.

Rumpelminz show me the right way.
The AU doesnt install with the MSI.

I installed with the exe -> Control the registry entries.
Now Export the AU entries and import the Regkeys on the machine
to install Java before the Java Installer starts.

Now all works fine.

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft]

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Auto Update]
"AUVersion"="2.1.9.5"

 

Answered 05/02/2013 by: derblitz
White Belt

  • Thanks, i rather like to add this reg value before MSI installation than install the AU after it ;)
Please log in to comment

Answers

1

So after you've executed your MSI/MST combination, "hide" the installation data and then perform a gap-captureusing the offline EXE. What you should get is what's missing/changed.

Answered 04/18/2013 by: VBScab
Red Belt

Please log in to comment
1

There is a silent command line to install Java.. Do not extract it.. Even i had problems.

Answered 04/19/2013 by: piyushnasa
Red Belt

  • This Answer is not good, for more as 8000 installations
Please log in to comment
1

Hi,

I had the same problem and came up with a solution because I really don´t want to use the .exe file. Here is what I did:

1, Install JRE with the exe into a VM, then check the AppData folder of the user, there should be a "au.msi" with a .cab file. It´s the autoupdater, it seems like the new JRE can´t start properly without it - and the msi install doesn´t install it automatically. When you install the au.msi, the control panel will work - BUT the Autoupdater will mess with your system. Copy these 2 files anyway, see step 3.

2, Prepare the JRE.msi with your settings (i.e. Disable Updates in property table)

3, Prepare the au.msi - I disabled all the custom actions that install the JU Task. I just left the Registry CA´s because I don´t want the JRE to update itself and pop up to the user all the time.

4, After you install those two .msi´s you still have to disable the au via the registry. Just set the 5 keys in JavaSoft\Java Update\ to 0.

It works, and no damn autoupdates or control panel errors.

Oracle should put more effort into their JRE packages, every new version something changes or doesn´t work anymore.

It got one problem left - we use the deployment.properties file in the windows directory to set the security level. This worked with earlier versions - but now it is completely ignored.

Hope I could help.

regards

Answered 04/23/2013 by: Rumpelminz
White Belt

  • this solution worked excellent! thanks for the help
Please log in to comment
0

Same thing on my side.  I just upgrade update 17 to update 21 on 2 VM workstation (WIN7 and WIN 7 64) on a lab environnement.  With GPO I remove the update 17 and push update 21.  Now I cannot open Java via the control panel on my 2 VM !!!  Anyone have an idea to fix this ?

Answered 04/25/2013 by: misabelle99
White Belt

Please log in to comment
0

Hi,

i got the same error in the Control Panel when i tried to install the MSI-File:

msiexec /I "%~dp0jre1.7.0_21.msi" /q AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0 IEXPLORER=1 Mozilla=1

Now i tried to install the *.exe with the /s command and also the parameters i used during the msi-installation - but they are not working:

jre-7u21-windows-i586.exe /s AUTOUPDATECHECK=0 JAVAUPDATE=0 JU=0 IEXPLORER=1 Mozilla=1

So i got a functional Java - with Autoupdater...

i tried to uninstall the Autoupdater:

msiexec /X {4A03706F-666A-4037-7777-5F2748764D10} /qn

and from now on the Control Panel got the same error as before..! Maybe there is a Problem with the missing Autoupdater?

Thanks for the support!

Answered 04/25/2013 by: secBIT
White Belt

  • Hi,
    see my post above, you need the Autoupdater! You can disable the task through windows settings and the registry keys under HKLM\Software\JavaSoft\Java Update\ (set to 0). I edited the au.msi and cleaned up all the custom actions regarding the JU Task, so the task was never installed.
Please log in to comment
Answer this question or Comment on this question for clarity

Share