I am not sure where to add the IP Helper Address for DHCP in our cisco switch. I am assisting a contract company. The DHCP server is WIN2008. I have already installed the necessary roles and DHCP is not handing out IP addresses. I have made sure that there is not any other DHCP servers on the network and there is not. I have restarted the server, services, authorized/unathorized with no availability. So, after some research I read about the IP Helper address. I have logged into the switch, but I am unsure where I need the command entered for it to possibly work. 


hostname Cisco-Switch
!
boot-start-marker
boot-end-marker
!
no aaa new-model
clock timezone UTC -6 0
clock summer-time UTC recurring
switch 1 provision ws-c2960s-24ps-l
authentication mac-move permit
!
!
ip domain-name blank
ip name-server 192.168.1.31
ip accounting-list 0.0.0.0 255.255.255.255
vtp mode transparent
udld aggressive

!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
crypto pki trustpoint TP-self-signed-3649066240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3649066240
 revocation-check none
 rsakeypair TP-self-signed-3649066240
!
!
crypto pki certificate chain TP-self-signed-3649066240
 certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
!
!
!
!
errdisable recovery cause udld
errdisable recovery cause bpduguard
errdisable recovery cause security-violation
errdisable recovery cause channel-misconfig (STP)
errdisable recovery cause pagp-flap
errdisable recovery cause dtp-flap
errdisable recovery cause link-flap
errdisable recovery cause sfp-config-mismatch
errdisable recovery cause gbic-invalid
errdisable recovery cause psecure-violation
errdisable recovery cause port-mode-failure
errdisable recovery cause dhcp-rate-limit
errdisable recovery cause pppoe-ia-rate-limit
errdisable recovery cause mac-limit
errdisable recovery cause vmps
errdisable recovery cause storm-control
errdisable recovery cause inline-power
errdisable recovery cause arp-inspection
errdisable recovery cause loopback
errdisable recovery cause small-frame
errdisable recovery cause psp
errdisable recovery interval 60
!
vlan internal allocation policy ascending
!
!
!
!
!
macro global description cisco-global
!
interface FastEthernet0
 no ip address
 shutdown
!
interface GigabitEthernet1/0/1
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/2
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/13
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/14
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/20
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/24
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.168.1.254 255.255.255.0
!
ip default-gateway 192.168.1.1
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
logging 192.168.1.15
snmp-server community public RO
!
!
line con 0
line vty 0 4
 password EnterPassword
 login
 length 0
line vty 5 15
 password EnterPassword
 login
!
ntp server 192.43.244.18 prefer
ntp server 192.5.41.40 prefer
end




























0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
Do you have the server trunked to the same vlans you are try to hand out dhcp on.  IP helper is for forwarding packets from one vlan to another.  It should make no difference for dhcp for the vlans the dhcp server is on

http://www.ciscopress.com/articles/article.asp?p=330807&seqNum=9

Do you have the ranges and other settings configured on the dhcp server? - See more at: http://www.itninja.com/question/ip-helper-address-for-dhcp#sthash.chBrz4H6.dpuf
Do you have the address pools and other settings configured on the dhcp server?



Answered 07/02/2014 by: SMal.tmcc
Red Belt

  • Yes, the whole network is on 192.168.1.1 -- 192.168.1.254

    I did not configure this switch initially.
    • If I remember you have a k2000 also. To see if it the server vs the network, do a test and temp activate dhcp on the k2000 for a small range and see if machines get IP's.
      • I do have a k2000 at my primary job. However, this is for a contract company. They do not have any Kace products.
      • Did you configure the address pool? What do the dhcp logs show on the server.
    • since you are on a single vlan iphelper should make no difference. could be acl's or some needed protocol is off.
      http://www.cisco.com/c/en/us/support/docs/ip/dynamic-address-allocation-resolution/27470-100.html
      http://www.cisco.com/c/en/us/support/docs/ip/dynamic-address-allocation-resolution/27470-100.html#roledhcpbootprelay
      • I have already configured the address pool. restarted services, authorized/unathorized dhcp. I have done everything I can think of. I have done this before for another company.

        In the end, I configured another server running the same server OS and installed all the roles and restarted the server and instantly IP address leases were being issued. Weird! Appreciate your help.
Please log in to comment
Answer this question or Comment on this question for clarity