I'm trying to package a certain app and after I capture it using adminstudio then try installing the package it gets to the very end and up pops "internal error 2502" and it says install failed. In all actuality though the install is successfull as it really installed. I've researced this but havent found a solution and was wondering if anyone has seen this before. Below is an except from the install log:

MSI (s) (54:94) [07:37:26:397]: Set LastUsedSource to: C:\Packages\.
MSI (s) (54:94) [07:37:26:413]: Set LastUsedType to: n.
MSI (s) (54:94) [07:37:26:413]: Set LastUsedIndex to: 1.
MSI (s) (54:94) [07:37:26:413]: Executing op: End(Checksum=0,ProgressTotal=176438037)
MSI (s) (54:94) [07:37:26:413]: Note: 1: 2203 2: C:\WINDOWS\Installer\364b30.ipi 3: -2147287038
MSI (s) (54:94) [07:37:26:413]: Note: 1: 2502
DEBUG: Error 2502: Called InstallFinalize when no install in progress.
Internal Error 2502.

MSI (s) (54:94) [07:37:31:727]: Product: Claims Administrator -- Internal Error 2502.

MSI (s) (54:94) [07:37:31:758]: Calling SRSetRestorePoint API. dwRestorePtType: 0, dwEventType: 103, llSequenceNumber: 7, szDescription: "".
MSI (s) (54:94) [07:37:31:805]: The call to SRSetRestorePoint API succeeded. Returned status: 0.
MSI (s) (54:94) [07:37:31:805]: Unlocking Server
MSI (s) (54:94) [07:37:31:820]: PROPERTY CHANGE: Deleting UpdateStarted property. Its current value is '1'.
Action ended 7:37:31: InstallFinalize. Return value 3.
Action ended 7:37:31: INSTALL. Return value 3.

THANKS!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
0
Worth checking

http://support.microsoft.com/kb/315636
http://community.installshield.com/showthread.php?t=150184 The sequencing issue is a good pointer...I wonder if InstallFinalize has become out of sequence? If should be either the last or one of the last entries in the InstallExecuteSequence table.
Answered 01/28/2008 by: VBScab
Red Belt

Please log in to comment
0
Yeah I'd already checked out both those solutions and neither helped unfortunately. Also it is the last command in the execute sequence as well. I'm officially stumped...
Answered 01/28/2008 by: rich872
Senior Yellow Belt

Please log in to comment
0
Hello all,

I had exactly the same error number as described. I tried to create a 2 packages EN and FR. The EN was OK but the FR exited with the logs:


...
L'action s'est terminée à 17:19:37: InstallFiles. Valeur de retour: 3
MSI (s) (DC:AC) [17:19:37:406]: Note: 1: 2502
DEBUG: Error 2502: Called InstallFinalize when no install in progress.
Une erreur imprévue est survenue pendant l'installation de ce fichier. Ceci peut être dû à un problème lié au fichier. Le code d'erreur est 2502. Les paramètres sont: , ,
MSI (s) (DC:AC) [17:19:38:046]: Produit: MyProduct -- Une erreur imprévue est survenue pendant l'installation de ce fichier. Ceci peut être dû à un problème lié au fichier. Le code d'erreur est 2502. Les paramètres sont: , ,
...

Nothing more to investigate: parameters are ", ,".

I then take the log of the EN version, the log of the FR version and begin to compare them. I was lucky and quickly found a difference in the first lines: I had forgotten to set up a ProductName for the FR version. This error is generic and can come from anywhere...

Hope this will help someone.
Regards,
-- NicoD
Answered 11/20/2009 by: NicoD
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity