Help needed... Has anyone figured out how to silently enable the ‘Use Windows to Manage Wi-Fi’ option? Any help with this is issue greatly appreciated, this really has me stumped. [X(]

There does not appear to be an option in the PROSet - ‘Administrator Tool’ – ‘Applications Settings’ to actually enable Windows to Manage Wi-Fi using an administrator package. The ‘Administrator Tool’ – ‘Wi-Fi Manger’ option only locks or unlocks the end users ability to manually use the “Use Windows to Manage WiFi” menu option.
In our environment, I need to have PROSet run to provide adaptor switching functions to multiple laptops and have Windows Managing Wi-Fi; basically co-existence of PROSet and Windows Wi-Fi manager. The PROSet - ‘Administrator Tool’ does allow for this and I have a PROSet administrator package that enables these features, but it does not actually turn on the “Use Windows to Manage WiFi” option.

Does anyone know if there a way to systematically enable the “Use Windows to Manage Wi-Fi” during the install using a command line option, an XML file function, or post-install using a registry setting, ini setting, etc? Thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Have you tried simply capturing the process to see what gets set?
Answered 11/02/2009 by: VBScab
Red Belt

Please log in to comment
0
No, but I tried to isolate the changes with Procmon to look at the registry and file changes. From what Procmon found it appears that PROSet enumerates registry keys based the type of wireless adapter that is in each machine. Those settings did not look promising since the solution needs to work on multiple computer models that have different wireless adapters. Thanks for the suggestion. I wonder if the PROSet install MSI has an option to enable Windows to control WiFi?
Answered 11/03/2009 by: PSA
Yellow Belt

Please log in to comment
0
Any luck on this one?

I'm in the same situation and haven't find anything to solve it, right know we are thinking of write instructions to the users and let them hand it manually.
Answered 11/12/2009 by: Bobo
Orange Belt

Please log in to comment
0
No answers on a Intel PROSet packaging option/solution, which is strange because Intel PROSet has so many install options. Also, this is not really that silly of a question since it is a menu option in PROSet. I posted to the Intel PROSet Forum also. I finally just wrote a robust Sendkey script that runs PROSet and then sends the key strokes as a post install function. This is not ideal but it works well. I utilized the AutoIt v3/SciTE ScriptWriter to get started. Best Regards
Answered 11/12/2009 by: PSA
Yellow Belt

Please log in to comment
0
One little issue is that the settings are per user, so you'll have to run that for the user that will be using the computer.

I just started a reinstallation on a computer and will see in a couple of hours if I've solved it, but I don't think so.

Will get back with result and some of the things I've tried without success.
Answered 11/13/2009 by: Bobo
Orange Belt

Please log in to comment
0
More important thing came up (thank you Adobe..), but today I had time to check on this again and solved it.

The setting is in this file:
C:\Documents and Settings\username\Application Data\Intel\Wireless\Settings\Settings.ini

Change XPNotInControl=1 to XPNotInControl=0 and you're done.

Or wait, the user has to do that, after Intel PROSet has been launched one time and created the file.

Perhaps you can set it in a another file?

Well, I tried these files with no luck:
C:\Documents and Settings\All Users\Application Data\Intel\Wireless\Settings\ItSttngs.ini
C:\Program Files\Intel\WiFi\bin\ItSttngs.ini
C:\Program Files\Intel\WiFi\bin\Settings.ini

So I ended up with running a rather nasty VBScript in Active Setup that waits for Intel PROSet to load and create Settings.ini, then it kills the processes iFrmewrk.exe and ZCfgSvc.exe, change the settings I want in the Settings.ini and then starts ZCfgSvc.exe and iFrmewrk.exe again.
Answered 12/11/2009 by: Bobo
Orange Belt

Please log in to comment
0
More important thing came up (thank you Adobe..), but today I had time to check on this again and solved it.

The setting is in this file:
C:\Documents and Settings\username\Application Data\Intel\Wireless\Settings\Settings.ini

Change XPNotInControl=1 to XPNotInControl=0 and you're done.

Or wait, the user has to do that, after Intel PROSet has been launched one time and created the file.


How about you use Self-healing or Active Setup to set this settings file for each user?

PJ
Answered 12/11/2009 by: pjgeutjens
Red Belt

Please log in to comment
0
ORIGINAL: pjgeutjens

More important thing came up (thank you Adobe..), but today I had time to check on this again and solved it.

The setting is in this file:
C:\Documents and Settings\username\Application Data\Intel\Wireless\Settings\Settings.ini

Change XPNotInControl=1 to XPNotInControl=0 and you're done.

Or wait, the user has to do that, after Intel PROSet has been launched one time and created the file.


How about you use Self-healing or Active Setup to set this settings file for each user?

PJ

So I ended up with running a rather nasty VBScript in Active Setup [;)]

And no, I don't have too much free time, that's why I can read upside down. [:D]
Answered 12/11/2009 by: Bobo
Orange Belt

Please log in to comment
0
I know your issue is resolved, but this string may answer questions for future questions. Instead of writing a VB Script to make to stop the services, make the changes, and restart the services, an easier way would be to manage the setting in a .MST.

In the MSI, the settings are stored under Components. This particular setting in question is named "WIFI_INI_XpInControl", so set the Condition to the following.

XPINCONTROL~="FALSE"

Then, use your tool of choice to create the MST.

Presto!

This same process can be used for any of the settings stored in settings.ini.
Answered 01/25/2010 by: sgg32
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: sgg32

I know your issue is resolved, but this string may answer questions for future questions. Instead of writing a VB Script to make to stop the services, make the changes, and restart the services, an easier way would be to manage the setting in a .MST.

In the MSI, the settings are stored under Components. This particular setting in question is named "WIFI_INI_XpInControl", so set the Condition to the following.

XPINCONTROL~="FALSE"

Then, use your tool of choice to create the MST.

Presto!

This same process can be used for any of the settings stored in settings.ini.

Thnas for the info, I'll look into this since my VBScript fails sometimes.
Problem is that I'm not involved in the hardware certification process, I'm just needed when they got problems like this... So I've to see if I can change the installation of the MSI.
Answered 01/28/2010 by: Bobo
Orange Belt

Please log in to comment
0
Actually, I just found a better way. Leave the media as is, and just update the setup.xml. Here's an example that I'm using. Focus on the <CustomerMSI> line. The line will most likely look much different for your puposes.

<?xml version="1.0"?>
<Products xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" version="2">
<OS name="XP">
<ProductName name="WiFi" desc="Intel(R) PROSet/Wireless WiFi Software">
<NativeMSI>/qf</NativeMSI>
<AddlocalMSI>ADDLOCAL=WIFI_Driver,WIFI_Software</AddlocalMSI>
<!-- ADDLOCAL= WIFI_SSO provides PST support for WIFI_NOSSO (NetProvCredMan, non-Gina) or WIFI_PLC (Gina PLC), WIFI_NOSSO and WIFI_PLC are mutually exclusive and should not both appear in the above feature selection list -->
<CustomMSI>DRFKILL=TRUE HIDEINFORMATION=TRUE HIDETASKTRAYOOBE=TRUE HIDETRAYICON=TRUE XPINCONTROL=TRUE</CustomMSI>
<AcceptUserCommands>True</AcceptUserCommands>
<PreInstallHookDLL>Dell.dll</PreInstallHookDLL>
</ProductName>
</OS>
<OS name="VISTA">
<ProductName name="Wifi" desc="Intel(R) Proset/Wireless WiFi Software">
<NativeMSI>/qf</NativeMSI>
<AddlocalMSI>ADDLOCAL=WIFI_Driver,WIFI_Software</AddlocalMSI>
<CustomMSI>DRFKILL=TRUE HIDEINFORMATION=TRUE HIDETASKTRAYOOBE=TRUE HIDETRAYICON=TRUE XPINCONTROL=TRUE</CustomMSI>
<AcceptUserCommands>True</AcceptUserCommands>
<PreInstallHookDLL>Dell.dll</PreInstallHookDLL>
</ProductName>
</OS>
<OS name="WIN7">
<ProductName name="Wifi" desc="Intel(R) Proset/Wireless WiFi Software">
<NativeMSI>/qf</NativeMSI>
<AddlocalMSI>ADDLOCAL=WIFI_Driver,WIN7_Driver,WIFI_Software</AddlocalMSI>
<CustomMSI>DRFKILL=TRUE HIDEINFORMATION=TRUE HIDETASKTRAYOOBE=TRUE HIDETRAYICON=TRUE XPINCONTROL=TRUE</CustomMSI>
<AcceptUserCommands>True</AcceptUserCommands>
<PreInstallHookDLL>Dell.dll</PreInstallHookDLL>
</ProductName>
</OS>
<MSI>Intel PROSet Wireless.msi</MSI>
</Products>
Answered 01/28/2010 by: sgg32
Senior Yellow Belt

Please log in to comment
0
Thanks again.

Using setup.exe and setup.xml seems like the easiest way, I will try to convince the Hardware/OS deployment guys to use that instead of MSI, the problem is that the policy is to use MSI as much as possible.
Answered 01/29/2010 by: Bobo
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity