Issue:
Create ODBC Connection based on Oracle version (9.x or 10.x) found on machine.

Done so far:
In WISE - Created a search property - ORACLEVERSION to look for launch.exe (search included to 10 folder depth)
In WISe - Created a variable in the Property Table. ORACLEVERSION, value =0
In WISE - Created a Feature OR9, added a condition to look for ORACLEVERSION = "C:\Oracle\Ora92\bin"
In WISE - Created another feature OR10, added a condition to look for ORACLEVERSION = "C:\Oracle\Ora10G\BIN"
On PC - Created an ODBC connection on the packaging machine, according to specifications for Microsoft ODBC for Oracle, with registration per machine.
In WISE - On the ODBC page, dropped down the feature for OR9 and OR10, and imported the above created ODBC datasource.
In WISE - Compiled the above package

Issue:
- I have Oracle 10 installed on the test machine
- On running the above package, it should have identified the launch.exe in the "C:\Oracle\Ora92\bin" and created the ODBC connecton.

The ODBC is not getting configured. Why?? What piece am I missing.

Seems like something is not getting linked together.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Not to sure if you have typed something incorrectly, but if you have Oracle 10 installed, surely it should identify the launch.exe in the "C:\Oracle\Ora10G\BIN" folder (you stated "C:\Oracle\Ora92\bin") and then then it should correclty configure your OR10 feature.

Like I say, I don't know if this is where your going wrong or if it's just typed in this forum incorrectly.
Answered 11/24/2008 by: michaelnowell
Second Degree Blue Belt

Please log in to comment
0
Michael, it's my job to not read posts properly, thank you! The OP has AppSearch set to look for LAUNCH.EXE, returning the folder name in ORACLESEARCH. Thus, the folder will be "C:\Oracle\Ora92\bin" for 9.2 or "C:\Oracle\Ora10G\BIN"for 10G.

@OP, I'd run the package through the Wise Debugger to trace what's going on. And I'd forget using WPS's ODBC "feature" as my experience with it has been universally bad. Import your .REG into the Registry view instead. Indeed, that may be all you need to do to get it to work.
Answered 11/25/2008 by: VBScab
Red Belt

Please log in to comment
0
Thanks all.
Above was a typo error in the forum only. My 'always' bad :)

Another thing I tried is adding a "\" ; so the path ended in BIN\ instead of BIN. That too did not work.

I will try the export of the ODBC.ini and ODBC Datasource keys and import them in the package
Answered 11/25/2008 by: aek
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity