Hello,

I ran the package and it seemed to have installed successfully but when I try to navigate to Library/KBOXAgent/Home/bin the directory doesn't exist. The agent appears to be running but the machine isn't appearing in the inventory. Any suggestions? Thanks in advance!

jimebong$ sudo SystemStarter start KBOXAgent
Password:******
Starting KBOXAgent
SMMPAgent is already running (8909)


jimebong$ ps aux | grep kagentd
jimebong 8999 0.0 0.0 75532 460 s000 R+ 2:36PM 0:00.00 grep kagentd
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Are you navigating to /Library/KBOXAgent/Home/bin (the absolute path, not the relative one, as you typed) as the root account?
Answered 10/04/2010 by: jkatkace
Purple Belt

Please log in to comment
0
Where does one actually get the package installer for OS X? I didn't see it listed in Software Library, just the KInstallerSetup.exe.
Answered 10/04/2010 by: davidc
Senior Yellow Belt

Please log in to comment
0
On a mac, navigate to smb://kbox/client/agent_provisioning/mac_platform.
Answered 10/04/2010 by: jkatkace
Purple Belt

Please log in to comment
0
ORIGINAL: jkatkace

Are you navigating to /Library/KBOXAgent/Home/bin (the absolute path, not the relative one, as you typed) as the root account?


That was my mistake, thanks!
Answered 10/04/2010 by: jimebong
Senior Yellow Belt

Please log in to comment
0
Cool thanks! If for some reason I were to prefer installing via the package installer via Apple Remote Desktop, would it by default start reporting to the K1000 without having to put the server name in the Configuration portion of the installer?
Answered 10/04/2010 by: davidc
Senior Yellow Belt

Please log in to comment
0
Only if the K1000 is named the default name. Here's what someone else reports:

I have deployed the mac client using ARD. We pushed the package and then sent the following commands using the “Send Unix Command” option 1. sudo SystemStarter stop KBOXAgent 2. sudo /Library/KBOXAgent/Home/bin/setkbox <kboxname> 3. sudo SystemStarter start KBOXAgent
Answered 10/04/2010 by: jkatkace
Purple Belt

Please log in to comment
0
BTW- THis is all for the pre-5.3 version of the Agent. Please check the latest Admin Guide and do a search for "ampagent" and you'll see information regarding install all three of the agents for Linux, Mac, and Windows.
Answered 03/14/2012 by: MacDude
Fourth Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share