I've created a simple installation that creates a folder under the users profile and copies some files into it. When I run the MSI logged on to the computer everything works correctly. When I try to push the package via GPO's the folder is created in the root of C:\

Any ideas why it would create the folder in the wrong location?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Is it a user based installation or computer based? ie: assigned to user or computer by GPO?

What is the folder path you are trying to install?
Answered 03/09/2006 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
Assigned User based Install. The app path is [userprofile]ini. Also in the install I set some app paths in the registry.

Basically I have an application that runs from a server (the actual EXE files reside on the Server along with the DLL's). The computers need to have the INI files and shortcuts. Before my company would put the INI files into the windows directory and every person that uses that computer would share the same INI file. I'm trying to get away from shared INI's and move them to the user's profile.

Thanks for the help,
Bill
Answered 03/09/2006 by: bcameron
Yellow Belt

Please log in to comment
0
The first thing you need to do in your MSI package is create a feature that contains the registry key that points to the users's specific INI file, the INI file itself, and an advertised shortcut (the targets at the exe).

The advertised shortcut is needed so that when the user logs on for the first time, that feature is installed for that particular user, hence the ability for individual INI settings.

The next trick is where I think you might be going wrong. By default, Windows Installer won't allow you to install anything to the root of the users profile. There is a workaround for this, but I suggest you should install the INI file to the Application Data folder, as Windows Installer supports this.

The Current User (HKCU) registy key value should be in the format of: [AppDataFolder]MyApp\filename.ini
For each user that clicks on the shortcut, a registry key value will be created in the expanded form of: c:\documents and settings\username\application data\MyApp\filename.ini

The only thing left now is the creation of the default INI file in the users Application Data folder.

Good luck.
Answered 03/10/2006 by: brenthunter2005
Fifth Degree Brown Belt

Please log in to comment
0
Thank you.

I will recreate my package and give it a try today.
Answered 03/10/2006 by: bcameron
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity