Hello all,

I'm new in this forum and I've no experience with SW packaging at all.

I have Checkpoint VPN client msi package, which I want to deploy the way that user sees installation, but can't cancel it and at the end of installation, there should be prompt for reboot.

I've tried install using command-line: msiexec /i package.msi /passive /promptrestart REBOOT=Suppress /l*v c:\temp\vpn.log

This shows installation for user, do not restart automatically, but it does not prompt user to reboot. What I'm doing wrong here?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
ORIGINAL: weedee
What I'm doing wrong here?
You have 2 conflicting directives: '/promptrestart' and 'REBOOT=Suppress'.

Delete 'REBOOT=Suppress'.
Answered 11/24/2008 by: VBScab
Red Belt

Please log in to comment
0
Hi VBScab,

Thanks for your reply.

I tried at first place with command-line: msiexec /i package.msi /passive /promptrestart /l*v c:\temp\vpn.log, but it conducted reboot automatically.
Answered 11/24/2008 by: weedee
Orange Belt

Please log in to comment
0
Apologies, I wasn't concentrating...looking in the log produced, what value has been assigned to the property REBOOTPROMPT?
Answered 11/24/2008 by: VBScab
Red Belt

Please log in to comment
0
There is no REBOOTPROMPT property in command-line I've used. Please see my post above.
Answered 11/24/2008 by: weedee
Orange Belt

Please log in to comment
0
ORIGINAL: weedee
There is no REBOOTPROMPT property in command-line I've used. Please see my post above.
Correct, which is why I asked you to look in the log which the command line produced in order to find out what value was assigned to it, if any.
Answered 11/25/2008 by: VBScab
Red Belt

Please log in to comment
0
Hello VBScab,

And thanks for your efforts helping me. Sorry for late response.

I tried to install this same package again with above command-line. I searched log file for REBOOTPROMPT and found these lines.

MSI (s) (A0:A4) [13:12:30:706]: Command Line: REBOOTPROMPT=S REBOOTPROMPT= CURRENTDIRECTORY=C:\ CLIENTUILEVEL=2 CLIENTPROCESSID=2588

MSI (s) (A0:A4) [13:12:30:753]: PROPERTY CHANGE: Adding REBOOTPROMPT property. Its value is 'S'.
MSI (s) (A0:A4) [13:12:30:753]: PROPERTY CHANGE: Deleting REBOOTPROMPT property. Its current value is 'S'.

Does this help to solve why auto-reboot occurs, if /passive option is used?
Answered 01/19/2009 by: weedee
Orange Belt

Please log in to comment
0
Ideas anyone
Answered 01/20/2009 by: weedee
Orange Belt

Please log in to comment
0
- Google, search term:
msiexec "/passive" -appdeploy
- First hit http://msdn.microsoft.com/en-us/library/aa372024.aspx
Answered 01/20/2009 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity