Hi All,

I have an MSI that I am updating to install for All Users. It previously would only install for a single user.

The installation is working fine but one file is not installing for each user.

The file is a database file that gets installed to My Documents/My Folder Name/my Db file.otb it creates the folder correctly for each user but does not install the my Db file.otb file.

Any ideas why it would not install the file for all users?

I am using Wise for Windows Installer Pro version 5.1

Thanks.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
So, where is the directory for the component holding the file located?
Did you set the ALLUSERS property to 1?
Answered 01/31/2009 by: AngelD
Red Belt

Please log in to comment
0
So, where is the directory for the component holding the file located?
Did you set the ALLUSERS property to 1?


Not sure what you mean by the directory for the component holding the file located. The file is saved in the MSI installer and then installed to the My Documents folder.

With the ALLUSERS property there is an option for the user to select All Users or Me Only during install. Can this also be set at a file level? If so where is it done as i can not find it.

Thanks.
Answered 01/31/2009 by: otrader
Senior Yellow Belt

Please log in to comment
0
Is your application having any shortcuts if yes make sure they are advertised, if still the file is not getting installed in standard user you may just opt for Active Setup since its an user data.
Answered 02/02/2009 by: shweta_kar
Blue Belt

Please log in to comment
0
SK, read the question. The OP wants to install the file for ALL users, not just one.

@OP, no offence, but I honestly don't think anyone here has the time to go into the detail required to properly answer your question. You need to do some serious research about Windows Installer and packaging. In particular, look at setting properties, the contents of the Directory table and what components are. Start at MSDN, where you'll find the Windows Installer Reference article.
Answered 02/02/2009 by: VBScab
Red Belt

Please log in to comment
0
@VSCab I have looked in MSDN and there is not useful info for ALLUSER settings... THey sayu set it to 0,1,2 and it will what you want. Hence the reason I am here. Believe me it is faster to search google and MSDN than wait for replies on message boards.

At some point you need to ask for help so here I am. As no one has repleid I assume it is not an easy answer or no one has had the problem (hence why I could not find anything)

@Shweta_kar
All the short cuts and alike are being installed correctly and the progrm runs fine. It is just the one file that doe snot get installed.
Answered 02/03/2009 by: otrader
Senior Yellow Belt

Please log in to comment
0
@VSCab I have looked in MSDN and there is not useful info for ALLUSER settings... That response serves to confirm that you need to do a lot more research/learning. Sorry, but there it is.

Re: your response to SK, you say now that the file is not being installed at all, whereas previously you were saying that it was being installed into the currently logged-in user's profile. Confusing...
Answered 02/03/2009 by: VBScab
Red Belt

Please log in to comment
0
ORIGINAL: otrader

So, where is the directory for the component holding the file located?
Did you set the ALLUSERS property to 1?


Not sure what you mean by the directory for the component holding the file located. The file is saved in the MSI installer and then installed to the My Documents folder.

With the ALLUSERS property there is an option for the user to select All Users or Me Only during install. Can this also be set at a file level? If so where is it done as i can not find it.

Thanks.



I think what AngelD's trying to say is for you to check the Directory column in your Component table (look for the component which contains the file), that will tell you which directory the file is getting installed to. With regards to the ALLUSERS property setting it to 0 = per user, 1= per machine, 2 = determined by user access (use your msi.chm). If that particular file is really that critical, try setting it as a keypath.

VBScab's all about tough love [:D]
Answered 02/03/2009 by: rbrucelee1978
Orange Belt

Please log in to comment
0
VBScab's all about tough love [:D]LOL...VBScab's all about people doing at least some of the work themselves. In this case, the OP is obviously a complete novice and, if you re-read through your response, take yourself back to day 2 of your packaging experience: does ANY of it make sense? To you and me, of course it does. To a newcomer, no. THAT is why I said that he/she really needs to do some work first: the question asked would probably be covered in the content of a training course, time I don't have (and I don't believe anyone else here has) time to devote to.
Answered 02/04/2009 by: VBScab
Red Belt

Please log in to comment
0
You're correct bruce,

However, he needs to check the folder "hierarchy" (parent directory connections) to find out if it's hard-pointed to the users profile.
My guessing is that it's set to PersonalFolder.

ALLUSERS=0 is not documentet and should not have any effect (but you never know with MS), non-defined (missing) in the Property table will set it as per-user.
Answered 02/04/2009 by: AngelD
Red Belt

Please log in to comment
0
I agree Ian, I usually do research on my own and if I really get stuck, that's the only time I generally ask for help... and again, you're correct because commonly used properties and table relationships do get covered in the WPS course both beginner and advanced.

Kim, I should frame that... getting a thumbs up from you guys is rare haha [:D]

Then again, not to sound like Ian but he'd still have to do research or try to work out on his own how to follow the folder hierarchy in the Directory table... not really that hard either but I'm not about to type that up here
Answered 02/04/2009 by: rbrucelee1978
Orange Belt

Please log in to comment
0
ORIGINAL: rbrucelee1978
Kim, I should frame that... getting a thumbs up from you guys is rare haha [:D]


Well, 9 posts is as rare it can be so keep it up and I'll make sure to rate you [;)]

/Kim
Answered 02/05/2009 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity