I am trying to image a Venue 11 Pro 7130 with Dell kace K2000.  I cannot get the keyboard to work or pull an ip address while it's on the dock in KBE environment. Docking station K10A.  I have done this on multiple Venue 11 Pro 7130.  We have about 50 of these tablets, same results.

Here what i have done.

- Upgraded my K2000 to firmware 3.6

- Load KBE drivers with WINPE4.0 and 5.0.  Recached the drivers, reinstalled WAIK and generated a new KBE boot disk.

- Disabled Secure boot, enabled legacy, booted from UEFI and Legacy.

- Connected an external USB HUB with the USB Flash Drive and connected a external NIC. I can take the same flash drive and external nic and connect it to a Lenovo Helix and i am able to pull a ip and image that device.

- Changed out the drivers

Is there a special driver i need for the keyboard or the network to work.

Here are the network drivers i used.



I followed this best practices for sccm too.



ALL and Any suggestions welcomed.

1 Comment   [ + ] Show Comment


  • I'm thinking it's a usb 3.0 driver.
Please log in to comment

Community Chosen Answer

You have to have a WinPE 5.0 KBE x64 no others will work correctly.  You need to add the usb 3.0 drivers to the KBE.  I have just finished imaging 12 of these.  I used usb 3.0 powered hubs and UEFI boot sticks.  I can do a scripted or deployed image to the tablets with that configuration.

You want to go to dell support and download the pe50 driver pack and add that to the kbe.

Answered 10/09/2014 by: SMal.tmcc
Red Belt

Please log in to comment


Have done some testing on a Venue Pro 11:

  1. Set BIOS to Legacy mode
  2. Use a docking station( K10A)
  3. Load drivers for docking station NIC to  \\k2000\drivers
  4. Load drivers for VenuePro in driverFeed, using Tablet 7130
  5. Rechace all drivers
  6. Build new KBE for Windows 8.1 in K2000 Media manager
Using this I have been able to deploy windows 8.1 x64 update 1.

Answered 10/09/2014 by: staveli
Orange Belt

Please log in to comment

The dock NIC for the 7130 Venue 11 will show up as one of the USB Storage Devices under legacy, not the IPV4 or IPV6 network adapter option. I could not pull IP using them. I was able to pull an IP address with USB Storage Device but I couldn't get past our custom Fog boot menu to get into the K2000. Mouse, keyboard, and volume up/down buttons stop working at this point. To get around that, in Kace I just made a USB boot stick of the WinPE 4.0 KBE drivers (showed up as a 3rd USB Storage Device) and that bypasses Fog and I can select an image as normal in Kace. No extra drivers needed for me but what was in the feed. After enabling the feed though, the name didn't match what the discovery vbs said, so I had to rename the folders in drivers_postinstall. You may want to run that vbs and verify.

Answered 02/14/2014 by: SDNBTP
Third Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity