Hi,
I am using wise package studio 7.0 sp2. In general information I can see, "Installer version 2.0". How can I create msi packages which have "Installer version 3" and above.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

2
look at the system requirements page "windows installer runtime version" you can set you installer version to 2.0 and above or as you said 3.0 and above

you will need to make sure you have installed the lastest windows installer engine on your workstation.
Answered 10/22/2009 by: cygan
Fifth Degree Brown Belt

Please log in to comment
2
That entry determines the minimum version to which your package will deploy. To package for specific versions merely involves using the particular features of that version. For example, one of the differences between v1 and v2 was the ability to digitally sign MSIs.

So, for example, if your package uses a v3-specific feature, set the 'Installer Version' to '3.0'. If it uses v3.1 features, set it to '3.1' and so on.

http://msdn.microsoft.com/en-us/library/aa372796%28VS.85%29.aspx
Answered 10/22/2009 by: VBScab
Red Belt

Please log in to comment
0
I did not get your point. I know there are updated Windows Installer versions available. Right now, whatever package [legacy or vendor msi]comes to me I do it. My Windows Installer version is set to 2.
As you are saying as per the package requirement set the installer value. Is it complicated process? How will I get to know, my package is using which Installer version?

My guess:

For legacy application, I can capture it, and create msi which will use version e.g. 3.1
For vendor msi, I will install it on the machine 1st, and if it gives an error for updated Installer version, then I will repackage that msi with updated, Installer version.

Please correct me, if I am wrong!
Answered 10/22/2009 by: Yaduveer
Orange Senior Belt

Please log in to comment
0
No. I'm saying that IF your package uses a feature of the WI engine which is specific to, say, v3, then you need to set the 'Installer Version' to 3.0.

Go mad - hit 'F1' when you're in the 'Installation Expert/General Information' view.
Answered 10/22/2009 by: VBScab
Red Belt

Please log in to comment
0
I got your point.
CYGAN and VBSCAB thank you for this useful information.
Answered 10/22/2009 by: Yaduveer
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity