On XP when I double click on an EXE from a vendor I get a window pop up that says: "Open File - Security Warning" "Do you want to run this file?"

1. How do you disable this?
2. Is it possible to run the same EXE via the CMD window and pass the EXE a parm that will silence this security warning?

Thank you.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


I have encounteres this before. You cannot edit any registry keys or pass any parameters to the exe in order to silence this. This information is stored within a different stream within the file.

If you goto the properties of the file however, towards the bottom you will see an 'UnBlock' button. Click this and you will no longer be prompted. You just need to make sure you use this copy of the file in your deployment.
Answered 04/23/2009 by: beefy66
Orange Belt

Please log in to comment

Is this happening when you run the .exe from a network share? If so, go into IE, select security, select intranet and click on sites. Then, check the "Include all network paths (UNCs)" option.

If this work, you'd have to look into modify your GPO (If you're in AD) to enable this setting.

Good luck,
Answered 04/23/2009 by: jcarri06
Senior Purple Belt

Please log in to comment
If you want to disable it temporarily (just to launch the exe) you can use this:

reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Associations /v LowRiskFileTypes /t REG_SZ /d .exe

then this again once you've finished (although group policy should auto-refresh and restore the security automatically)

reg delete HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Associations /f

Hope it helps,
Answered 04/24/2009 by: MSIPackager
Third Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity