We recently moved our K1000 from a client data center to a Dell data center. Previously the appliance did not have smtp specified and so when I sent to @client.com it used the client smtp and when I sent to @dell.com it used the Dell smtp server. Well Dell considers any network in their data center internal, even if only client machines are on it, and will not allow you to send through their SMTP from an internal address. So I switched to the client smtp server, got them to add the ip of the appliance to the approved sender list, and under Service Desk, Configuration, Queues  set the From address to no_reply@client.com.  When I run tests with the diagnostic tool I can send to both client addresses and Dell addresses. Apparently KACE does not use that setting for error messages or reports. Kace support saw in the logs that error messages set the from field to the same as the to field specified in general settings. So I get a to: myteam@dell.co  from:myteam@dell.com and the client smtp rejects the message. Reports seem to use some other address entirely as I tried to send a report to my Dell address and a client address and neither of us got it. I have been told by the exchange admins that work on the client servers and the ones that work on the Dell exchange servers that the problem is the from address and they cannot change their settings for security reasons. Anyone have any idea of how to force KACE to use the same FROM address on everything?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity