Hi!!!

We have created an multi-user distribution point for OpenOffice2.0 using the switch

/...../setup.exe /a and sucessfully deployed the software to the machines in our school using GPO-based Software Installation.

The problem we are having are that the file associations doesn't get set automatically for .doc, .xls etc.

Has anyone done this with a MST-file or can you perform this by adding a switch to setup.exe when you create the administrative distribution???

I have checked the one solution for OpenOffice2.0 in the packages section, but I didn't not understand that soulution, using the msiexec command.

Basically this our first major use of GPO-Based installations, when only previously done this for Adobe Reader 7 and made changes using theirs Tuner to create a MST file with our changes. So if I have missed any basic information, I do apologize...

Best regards
at
Sweden

Edit: Spelling
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi american:

I believe you must have got an MSI for open office 2.x either this would be available in the setup directory or on the network folder where you have extracted the admin install files. so any msi that you find in either of these directories go to the run box and type this command:

msiexec /qb! /i c:\setup\openofficeorg19122.msi ALLUSERS=1 SELECT_WORD=1 SELECT_EXCEL=1 SELECT_POWERPOINT=1

c:\setup\openof********.msi is a path to the msi of open office, once you run the above command then it will register doc,xls and ppt files with open office. Thats what has been explained in the packages section. In case you require further help on the same kindly revert back.
Answered 09/06/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
Hi Bhupesh and thanks for the reply!!!

So what the "msiexec /qb! /i c:\setup\openofficeorg19122.msi ALLUSERS=1 SELECT_WORD=1 SELECT_EXCEL=1 SELECT_POWERPOINT=1" do is that it opens the msi-file and set the parameters in the msi-file so the that the files will be associated to OO2 and make the installation type silent, so if you re-deploy the OpenOffice installation in the GPO the Group policy, OpenOffice will be installed again with the files correctly associated? Did I understand it correctly?

Best regards
at
Answered 09/07/2005 by: americantabloid
Senior Yellow Belt

Please log in to comment
0
Hi American:

You got it right! actually the command specified calls the MSI silently and associate the files with appropriate oo2 applications and AllUSERS is used for per user installation. If you re-dploy the MSI again thru GPO it would probably remove or modify the application, however I would suggest that you should uninstall the MSI deployed already and then use the above command and then it would associate the files correctly. I hope this would solve the stalemate.
Answered 09/07/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
Thanks!!! It's working.[;)]

Best regards
at
Answered 09/08/2005 by: americantabloid
Senior Yellow Belt

Please log in to comment
0
Hi

In our company we're also dealing with the same problem. Following instructions, after running the syntax
msiexec /qb! /i c:\setup\openofficeorg19122.msi ALLUSERS=1 SELECT_WORD=1 SELECT_EXCEL=1 SELECT_POWERPOINT=1

OpenOffice is installed localy on my system. Then I took openoffice.msi file that had to be changed, and deployed it to a test computer through a GPO, but still associated values are not regitered? Really don't know why??
Regards
Miha
Answered 10/12/2005 by: bernikm
Yellow Belt

Please log in to comment
0
Hi Ber:

Try changing ALLUSERS=2 since this would perform per machine installation. In case doesnt work let me know
Answered 10/12/2005 by: wiseapp
Second Degree Green Belt

Please log in to comment
0
Hi again!!!

We also have been having some problems, with the installation.

Please ignore my previous post "It's working".

I was almost sure that the installation went ok...I checked and double checked I thought...We have issues with severaly machines, were the changes hasn't taken effect.

We are going to wait for the final build until we willl be doing any changes. It's seams not to be to far away.

Please Bernikm, keep us updated with the results.

Best regards
at
Answered 10/14/2005 by: americantabloid
Senior Yellow Belt

Please log in to comment
0
Hi

We also tried with ALLUSERS=2 parameter, but still the same - associated files are not getting registered after asigning application to a computer.
I'm assuming that the openoffice.msi file is not changed (looking time of a file) in any way, that this whole string only works to install OpenOffice locally.
A firend suggested me to use InstallShield Repackager to configure installation in a way you want it. I'll give it a try tomorrowtom
Regards
Miha
Answered 10/16/2005 by: bernikm
Yellow Belt

Please log in to comment
0
Guys ..

its kind of obvious you haven't dealt much with msi-based installations before :-)

The easiest way for you to go about setting the properties would be to open the openoffice msi in Orca (get it from the Platform SDK), create a new transform and then set the required properties in the Properties table. Save the transform, then apply it to the main msi when you create your group policy object.

Good luck :-)

Thank you very much to the OpenOffice folks that made a very right decision about using Windows Installer for OO2.
Answered 10/24/2005 by: jib
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity