Hello,
I'm attempting to create IE8 installation package for our users. Among one of many customizations, I want that IE8 Favourites Bar is free of default links eg. "Free Hotmail" and "Customize Links". I've created my MSI package with IEAK8 and on Browsing Options page of IEAK, I've selected ticked all boxes under "Do not add Microsoft default" Favourites, Web Slices and Links etc.

However, when I install MSI package to my test box, "Free Hotmail" and "Customize Links" entries are displayed on the Favourites Bar. How I can get rid of these? Am I doing something wrong with IEAK?

I'm deploying IE8 only to Windows XP SP3 boxes.[/align]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I suppose this is because your latest package is reading settings from HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main registry. Please remove the same manually before installing your packaged MSI and check.
Answered 04/26/2010 by: Yankir
Senior Yellow Belt

Please log in to comment
0
Hi Yankir,

Thanks for your reply. I couldn't find any entries in HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main related to Customized Links or Free Hotmail.

Maybe I didn't understood you correctly?
Answered 04/26/2010 by: weedee
Orange Belt

Please log in to comment
0
I mean,you need to remove HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main registries (like "Start Page" etc... which you don't want to be inherit by IE8) from the machine on which you are installing IE8 package.
Answered 04/26/2010 by: Yankir
Senior Yellow Belt

Please log in to comment
0
Ok, I got it.

But like I said, there's no registry entries under that key which bring up eg. Free Hotmail entry to Links bar.
Answered 04/26/2010 by: weedee
Orange Belt

Please log in to comment
0

Sorry I interpret it incorrectly .I think what you have done is correct.

We have selected below two settings for IE8 package which I am using and I doesn't have unwanted Link bar.
a) Don't delete any item
b) All the check boxes under "Do not add Microsoft default".
Answered 04/26/2010 by: Yankir
Senior Yellow Belt

Please log in to comment
0
If you install your IE8 package to fresh built computer and enable Favourites Bar from View/Toolbars, there's no "Free Hotmail" or any other MS default links, right?

I can delete those unwanted links from IE6, but as soon as I install my IE8 package, it installs also those default links.
Answered 04/26/2010 by: weedee
Orange Belt

Please log in to comment
0
Other ideas?
Answered 04/27/2010 by: weedee
Orange Belt

Please log in to comment
0
Weedee, I am unable to reproduce issue reported by you.

Setting mentioned by you for Browsing Options dialogue is used by me as well.

In one of the customization screen (unable to recollect its Name right now), all the default links were deleted from the Favorites Bar, not sure if you also did the same..
Answered 04/27/2010 by: Yankir
Senior Yellow Belt

Please log in to comment
0
Yankir, I just checked my package with IEAK8 and I've selected all four option from "Do not add Microsoft default".

When you install your package with these options, could you check from machine c:\documents and settings\default user\facourites\links folder if there's files created during installation? In my case, those unwanted links are created to that folder.
Answered 04/27/2010 by: weedee
Orange Belt

Please log in to comment
0

Apart from the configuration we did in Browsing Options dialogue, extra settings we have done in Favorites, Favorites Bar and Feeds dialogue.
I have also removed all the URLs/Weblink which was by default coming under Favorites (like Microsoft Websites), Favorites and RSS Feeds + CHECKED "Disable Internet Explorer Suggested Sites" option.
[font="times new roman"]
We have tested this by installing our package on IE6 and rebooting the machine, it works.
Answered 04/28/2010 by: Yankir
Senior Yellow Belt

Please log in to comment
0
I appriciate your efforts helping me with this. I have too removed all URLs and weblinks from that dialog page and checked that same setting, but still "Free Hotmail" link is displayed.

Maybe there's hotfix/update which is causing this.
Answered 04/28/2010 by: weedee
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity